IDEA 10.0.1 locking up on Sync

I use IDEA for my primary IDE and Eclipse for Clover (at this time we only have licenses for the Eclipse plugin).

I am trying out the IDEA 10 Evaluation, since we use TFS 2010.  I'm seeing some bugginess, but the biggest problem that I'm seeing is that if I update a file in Eclipse, that IDEA seems to lock up and never recover.  I have to kill the task in Task Manager.

In IDEA 9, this worked just fine and IDEA picked up any file changes immediately and properly refreshed the file.  This appears to a regression in IDEA 10.

5 comments
Comment actions Permalink

Hello Angella,

Please attach the contents of %USERPROFILE%\.IntelliJIdea10\system\log (including
the threadDumps directories).

I use IDEA for my primary IDE and Eclipse for Clover (at this time we
only have licenses for the Eclipse plugin).

I am trying out the IDEA 10 Evaluation, since we use TFS 2010.  I'm
seeing some bugginess, but the biggest problem that I'm seeing is that
if I update a file in Eclipse, that IDEA seems to lock up and never
recover.  I have to kill the task in Task Manager.

In IDEA 9, this worked just fine and IDEA picked up any file changes
immediately and properly refreshed the file.  This appears to a
regression in IDEA 10.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I've also started noticing really strange auto-complete issues today.  I will be using auto-complete using keystrokes and then when I press enter to select the variable name, I will get a bunch of spaces in the code with some weird highlighting and my selected variable will not be inserted into the code.

I

0
Comment actions Permalink

I'm not able to upload the log files into your system.  I've tried several times, and each time it appears to timeout or something.  Do you have an email address I can send them to?

0
Comment actions Permalink

Hello Angella,

You can send them to me at yole@jetbrains.com

I'm not able to upload the log files into your system.  I've tried
several times, and each time it appears to timeout or something.  Do
you have an email address I can send them to?


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

This problem was significantly improved with 10.0.2, and I've submitted a bug with the thread dump to the Issue Tracker for a lock up after upgrading to 10.0.2.

0

Please sign in to leave a comment.