3273 compilation / module JDK problem

I'm been working on an IDEA plugin project. It has 2 modules, one is Java,
the other is Plugin. The Java must be compiled with JDK 5.0, the Plugin must
be compiled with 1.4.2 (with IDEA plugin JDK) and the early access GJC javac
from Sun.

My problem is, I keep getting "invalid class version 49.0" when trying to
load my plugin into idea debug session. This must mean that it's being compiled
with the JDK 5.0, even though it's set to use the IDEA JDK.

I haven't worked on this project in a while, so maybe I've forgotten some
special build step, but I can't figure out what could be wrong. I think it
might be a problem in the latest EAP.

I even tried removing the Java module from the project, so the project is
only the plugin module, and the only JDK present is the IDEA JDK. So, there
should be absolutely no way for the compiler to be producing classfile 49.0,
because that was only introduced in Java 5.

Has anyone else had this problem? Does anyone know what I can do to fix it
or get around it?

Thanks


Please sign in to leave a comment.