What happened to Back/Forward?

Since late in the 10 EAP and into the current EAP, Back and Forward seem to go to abitrary locations. This such a central feature that try to convince myself that I must be doing something wrong.

Does anybody but me find that this no longer works. I use split mode almost exlusively, and I now I also tend to keep some files open in my second monitor. I know there are lots of other problems with split mode (ie, find and debugger will /always/ open a file in the group with focus rather than bring focus to a file already open in an other group), so could it be just that?

In any case, this is killing me.

7 comments
Comment actions Permalink

On Tue, 25 Jan 2011 02:42:33 +0000, Barry Kaplan wrote:

Since late in the 10 EAP and into the current EAP, Back and Forward seem
to go to abitrary locations. This such a central feature that try to
convince myself that I must be doing something wrong.

Does anybody but me find that this no longer works.


Yeah, I do.  And I've not filed a bug report about it because it's so
broken I don't know where to start with a description.  Poor excuse, I
know.

I use split mode almost exlusively


I also use split mode (two groups side by side) and I've always assumed
the fact I have only one file per group (tab placement "None", tab limit
"1" in the editor settings) is relevant.

and I now I also tend to keep some files open in my
second monitor. I know there are lots of other problems with split mode
(ie, find and debugger will /always/ open a file in the group with focus
rather than bring focus to a file already open in an other group), so
could it be just that?


I don't think it's just that as I now see it when navigating backwards -
the other group seems just to be ignored.

In any case, this is killing me.


Yep, it's a real pain.  Time to find time to file a report.

--
Mark Scott
mark@codebrewer.com

0
Comment actions Permalink

Are you sure you have the latest EAP build (102.216)?

http://youtrack.jetbrains.net/issue/IDEA-22870

Bas

0
Comment actions Permalink

On Tue, 25 Jan 2011 15:33:41 +0000, Bas Leijdekkers wrote:

Are you sure you have the latest EAP build (102.216)?


Speaking for myself, I hadn't noticed that build so thanks for pointing
it out.

http://youtrack.jetbrains.net/issue/IDEA-22870


This doesn't fix the problem for me.  Navigating back still fails to take
account of the editor groups as it will open a file in the current group
when it's already open in the other group.

Will a comment on the now-closed IDEA-22870 be noticed or should I create
a new report?

--
Mark Scott
mark@codebrewer.com

0
Comment actions Permalink


http://youtrack.jetbrains.net/issue/IDEA-22870


This doesn't fix the problem for me.  Navigating back still fails to take
account of the editor groups as it will open a file in the current group
when it's already open in the other group.

Will a comment on the now-closed IDEA-22870 be noticed or should I create
a new report?

Also already in YouTrack. See and vote:

0
Comment actions Permalink

This back/forward issue drives me crazy as well, I can't wait to try the EAP. I just noticed the frame focus issue the other day as well, if you file an issue please paste the link here, I'll happily vote it. I haven't searched for an existing issue BTW, there may already be one - a quick search for "frame focus" didn't find anything that looked relevant.

Cheers,
Colin

0
Comment actions Permalink

Thanks Bas, you beat me to it. See particularly http://youtrack.jetbrains.net/issue/IDEA-63726 which is a fantastic bug report (described, debugged, analysed and patch supplied).

0
Comment actions Permalink

Yes, I am using 102.216.

0

Please sign in to leave a comment.