Error downloading list of plugins

When I open the Plugins Manager for IntelliJ IDEA I see the following error after it downloads the latest list of plugins:

List of plugins was not loaded: The reference to entity "id" must end with the ';' delimiter.

This occurs on my Linux and Mac laptops using version 10.0.0 and 10.0.1. Is there something wrong or defunct with my installations or is this a problem with the plugin server?

7 comments

Looks like it must be the plugin server, a couple of us have started seeing
the same thing:

http://devnet.jetbrains.net/message/5284029

When I open the Plugins Manager for IntelliJ IDEA I see the following
error after it downloads the latest list of plugins:

List of plugins was not loaded: The reference to entity "id" must end
with the ';' delimiter.

This occurs on my Linux and Mac laptops using version 10.0.0 and
10.0.1. Is there something wrong or defunct with my installations or
is this a problem with the plugin server?

---
Original message URL:
http://devnet.jetbrains.net/message/5284025#5284025



0

I am getting the same thing. I opened a bug report on it: http://youtrack.jetbrains.net/issue/IDEA-64390

This gets reported periodically. In the past it has been a problem on the plugin server that needed fixing. (See IDEA-52346, IDEA-55305, & IDEA-59963).

0

Same here. Must be something wrong on the plugin server.

0

I'm seeing this as well.. Can I manually install the plugin somehow?

0

nevermind, got it.. just copied the .jar file to the plugins dir in the package


0

I just traced the traffic downloaded when "Reload" is clicked (using Wireshark) and it looks to me like the culprit is a plugin called "Statistic" in the "Reporting" category.
The url specified by the author for that plugin is contains an unescaped ampersand:

<idea-plugin downloads="4244" size="127768" date="1295451432000" url="http://plugins.intellij.net/plugin/?idea&id=4509">
<name>Statistic</name>
<id>Statistic</id>
<description><![CDATA[Shows project statistic. This plugin shows files sorted by their extension along with size, line count LOC etc.
        User can select (Project/Module/Package/File) scope using the 'Refresh on selection' button. (This plugin requires Java 1.6)
    ]]></description>
<version>2.0</version>
<vendor email="tomas.topinka@jpower8.com" url="http://www.jpower8.com">Ing. Tomas Topinka</vendor>
<idea-version min="n/a" max="n/a" since-build="80.8000" until-build="0.0"/>
<change-notes><![CDATA[        ]]></change-notes>
</idea-plugin>


Cheers,
Andrew.
0

Please sign in to leave a comment.