Error running WorldServer: Unable to open debugger port: java.net.SocketException "socket closed"

I am running IDEA 9 attempting to debug our web app via Tomcat 5.5  running within the IDEA environment. Running the app works fine; however, all attempts to debug in this configuration fails with the above error message (which can only be seen once I end the debug session.) All breakpoints are ignored.

I have tried running with Java 1.4 and Java 1.5. I can get debugging working properly with Tomcat 4.

Any ideas or suggestions as to what might be going on? (Note I have rebooted, as well as tried the shared memory option for the debugger -- neither worked).

Thanks

2 comments
Comment actions Permalink

It appears that at least for my scenario, this issue was minimally related to a change in the server.xml file for Tomcat as packaged without our product. Using a vanilla installation of Tomcat 5.5.17 resolved the issue.

0
Comment actions Permalink

Thanks for the answer.I was using Tomcat 5.5.12 and upgraded to Tomcat 5.5.31 + With JDK 1.4 Compatability Package It also solved the problem.
I think it is the problem of jdk 1.4. anyway, this solves:)

0

Please sign in to leave a comment.