Mouse right-click context menu bad behavior under linux


right-click under linux doesn't work as supposed to work. When I right-click (in any editor/pane in IDEA), context menu should appear, but I see only 0.1 sec flicker of context menu and it immediately disappear. When I want to access context menu, I must use workaround:
1, click and hold right mouse button on editor/pane
2, while holding, move mouse a little to left and bottom to select something from context menu

this way context menu stays on the screen and I can access it, but as you see this approach is quiet inconvenient. Does anybody experience similar behavior?

IDEA 7.0.1, Debian Lenny 32-bit, KDE enviroment


nobody has similar problem? should I post a bug?


I think this is a problem specific to your environment and/or configurations settings.

I've been running IDEA on Linux for years now (starting with 4.5) and I can't remember ever experiencing the problems you describe.


yes, I'm sure its my enviroment related, and that is thing that surprise me, because Debian 32-bit is pretty common linux distribution. I could say that almost most common, but I don't want to get into flamewar :>
However I found something like this in file>


  1. There are two possible values of idea.popup.weight property: "heavy" and "medium".

  2. If you have WM configured as "Focus follows mouse with Auto Raise" then you have to

  3. set this property to "medium". It prevents problems with popup menus on some

  4. configurations.

  5. ---------------------------------------------------------------------


I tried to change it to 'medium' but problem is even worse then. Maybe I'm facing something bigger here, because my IDEA is working very slowly at all, much slower than eclipse and netbeans witch I use occasionaly. For example simple ctrl+space autocompletion takes about 3x much time than in eclipse.


Hmmm, that's weird.

You could try cleaning up the ~/.IntelliJIdea70 directory. Maybe there are some (old) caches or settings in the way?

A property I always change on Linux is the following:


  1. IDEA copies library jars to prevent their locking. If copying is not desirable, specify "true"



By default it's false. But since when does Linux have problems with file locking? I don't know if it actually makes IDEA faster (or slower) but it does save some disk space...



thanks for suggestions, however I still don't feel like I'm on the way to solve this...
my idea installation is 2 weeks old and it behaves like this from beginning (I mean pop-up context menus flickering and slowness in auto-completion and browsing and all)

here are some of important settings in my property file>


I tried to play with these a lot but none of them was helpful for me. I suspected my JDK at first, but I double checked my JAVA_HOME and JDK_HOME are pointed to Sun's JDK6, not crapy GCJ that comes with linux at default.


I crosschecked your properties against mine. There are 2 differences:

idea.fatal.error.notification=disabled (not commented)

Especially the first one may have some impact:


  1. Disabling this property may lead to visual glitches like blinking and fail to repaint

  2. on certain display adapter cards.



Message was edited by:
Vincent Oostindie


hmm, I tried to change those 2 before, but unfortunately it doesn't help...
I will try some liveCD linux distributions with IDEA in next few hours and hopefully will find out something.


Good luck!

For the record: I'm on Mandriva 2008.0. Works fine and they have a LiveCD I believe...


OK, I think I'm closer now. I tried it on clean debian install - it works! Then I tried to backup and remove my profile idea folder $HOME/.IntelliJIDEA and start with clean install of IDEA - it works again. So there is definitely something that is screwed-up in my profile folder. I will try to import back my settings and plugins one after one to see what was the problem. Maybe it was just some bad cache issue you suggested first.
BTW, I upgraded to 7.0.2, but it doesn't have any influence on the issue we are talking about.


OK, after almost 3 hours of struggling with my profile and settings. and after countless IDEA restarts I've got it. Surprisingly it was my custom keymap that caused the problem. Attached is file that was cause of all of this - /home/samopal/.IntelliJIdea70/config/keymaps/samopal.xml
I added only few custom keys to IDEA to make myself more confortable with it, but somehow it ended up like this. I don't have more strength to discover which of those settings ruined context menus in all IDE windows, my guess is it was something with clipboard.

So for now, problem solved. Only thing that remains bothering me is slow auto-completion of methods (ctrl+space). No big case, but it is definitely slower than in eclipse and it would be nice to have it faster, but that is for another topic :>

EDIT> also when I try to change keymap only to 'eclipse' theme, context menus are ruined altogether, so this is nothing I did, it is eclipse keymap what did it :>


Glad you found it.

I also have my own keymap (with minor additions to the default) and never had any problems. However, when I switch to the Eclipse keymap, I get the same problems you had.

I guess this would be worth an issue in JIRA...

Regarding the Ctrl+Space auto-completion: it almost instantaneous on my environment. So it should be able to work correctly, I guess. (But I can't compare it to Eclipse, because I never use it.)


The problem resolved (see below).

I've just updated kde 3.2 Debian sarge to kde 3.5 Debian lenny (just using dselect, packages update, dpkg --install/remove etc, like it required some magic for removing/updating all the packages). As result, everything is exelent, except of the same problem with right mouse click.

I understand now that the problem is that the "click" is duplicated. Like I click mouse once, but in some cases it gives two clicks. It looks just like first time I clicked right mouse button the menu appeared, but as soon as second click passes the menu goes away, so I cannot open a menu   Very prostrating. The same problem for "middle mouse buttom == paste": it makes text paste twice.

In some applications if you hold mouse button, the menu appears again, so for example in Konqueror the menus always works Ok, but in Mozilla Firefox you cannot either use File/Edit/etc menu and both control menus of form menus that appears as result of left or right mouse clicks..

For the first the problem occured for 2.6.18 personally built kernel only, but the problem didn't occured for prebuild auto installed new kernel 2.6.26, so I thought that the problem is related to hardware.. Then I guessed that the problem in configuration.. Now I can see that the problem is in duplication of kde configuration files, because of kde-upgrade, so probably the problem doesn't occur for clear-installation.

Right now I'm investigating files /usr/share/config.kcfg and  ~/.kde/share/config/ trying to understand anything (searching for duplications)..
I don't have any experience with kde-developing, so I don't understand these files structures/logic at al.
If you can help me in someway, tell me what to do or how to update the files to clear installation (just to remove ~/.kde/share/config? ) so I can understand step by step what makes such a case.

Note that there are a lot of people around the world who got the same problem during XFree86/kde/GTK+/etc upgrade, but it looks like there are still no answers in google yet.

Also I get warn message "Cannot fine kstartupconfig. Check yours kde installation" during KDE startup. It didn't appear for the first (after installation and KDE worked well), but then it began to appear. I cannot find thie file (kstartupscript) anywhere. I tried "cp ~/.kde/share/config/startupconfig ~/.kde/share/config/kstartupconfig", but it didn't help (message still occur).


Resolved. The problem was in xorg.conf (name before XF86Config-4).
I guess the problem was that I missed
Option      "CorePointer"
for Mouse section.

E.g. this one makes "double click" problem

section "InputDevice"
# Identifier and driver
    Identifier  "Mouse1"
    Driver "mouse"
    Option "SendCoreEvents" "true"
    Option "Protocol"   "PS/2"
# ImPS/2
    Option "ZAxisMapping"   "4 5"
    Option "Device"     "/dev/input/mice"
#    Option "Device"     "/dev/psaux"


and this one works well (there is no double-click error):

Section "InputDevice"
   Identifier  "Mouse2"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/psaux"
   Option      "Protocol"    "PS/2"
   Option      "Emulate3Buttons" "true"
   Option      "ZAxisMapping"    "4 5"

I don't understand what was exactly the reason of the problem. It looks like I had both two mouses before

    InputDevice "Mouse2"
    InputDevice "Mouse1"

and it worked well for kde 3.2 (debian sarge), but for some reason it makes problem for debian lenny, so I have now

    InputDevice "Mouse2"
#    InputDevice "Mouse1"

and this one still makes double-click problem (so I thought that this is before of CorePointer param):

#    InputDevice "Mouse2"
    InputDevice "Mouse1"



While you may have found a workaround, this is clearly not the issue.  Right clicking works just fine in the same environment if you have a keymap other than Eclipse.  Plain and simple.  There might be some sort of incompatibility between the keymap IDEA is using for Eclipse (for some reason) and something within the environment, but this doesn't explain what that could be.  This also doesn't happen in any other application for me, just IDEA and only when the keymap is switched to Eclipse.


Here is my solution:
remove "Button3 Click" shortcut from Other -> Show Context Menu.

PhpStorm 1.0.1 build #PS-95.503,
Ubuntu 10.04.1 LTS


i had the exact same problem on mac osx 10.5.8, and can confirm that removing Button 3 Click fixed the problem for me too. thanks mirek.


Eight years later, I had this same issue suddenly occurring. I'm not entirely sure when it first happened, but I think it's from a PyCharm upgrade and I'm also fairly sure that nothing else in my system configuration has changed at the same time, but it's hard to rule out entirely.

I'm using PyCharm 2018.2.1 with the window manager i3 on Debian. For me, this was fixed by disabling the focus follows mouse configuration flag, which makes the window currently hovered over receive input focus.

No idea what that has to do with the context menus, but maybe the context menu isn't spawned 'under' the current mouse cursor position, but instead a little bit down and to the right, so whenever the context menu opened up, 'focus follows mouse' would immediately detect that I'm not hovering over the context menu but over the main windows, and then give focus back to main window, thereby immediately closing the context menu. Just an idea, could be a hundred other things as well.


@Henrik you could also try disabling suppress.focus.stealing option in registry (Help | Find Action... , type Registry, find the key and disable it).


Mirek Wróbel solution works for me (Remove "Button3 Click" shortcut from Other -> Show Context Menu.)


it took me way to long to find this post. It was slowly driving me insane that I had to right-click multiple times for the context menu to appear. For me it was not exactly the described solution but it pointed me in the right direction. I had to unassign "Right-Click" shortcut from Other -> Show Conect Actions. In case anybody in the future has the same issue and Button3 Click solution as described above does not work.


Please sign in to leave a comment.