Ver 10 - Grails module dependency does not 'stick'.

Hello all,
I'm working a plugin intensive project and wondering if anyone else has an issue regarding adding a module to a Grails plugin's dependency list and it not 'sticking'?

The steps to reproduce the issue are...
- Open the Project Structure dialog and select a module to add a dependency (eg. modA)
- Select the Dependencies tab and choose the Add.. button
- Select the Module Dependency... item and highlight the module (eg. modB) to add. Press OK.  You should see the added module in the list.
- Finally, select OK to apply and dismiss the Project Structure dialog

When I return the the module's project structure (modA) and check it's dependencies, the module that I added (modB) is not listed.  

I've tried selecting Apply then OK - same result. As well, I selected the export check-box with the same result.

This was working in v9.4. It appears to be new behavior in v10.

One tidbit - I *can* add my home-grown plugin (modB) to the module-grailsPlugins module (eg. modA-grailsPlugins) and life is a little better (it compiles). However, I'm unable to debug (eg. stop at a breakpoint).  The reason is that the module-grailsPlugins is using the source found in the ~/.grails directory and *not* my original source tree.

Your ideas are greatly appreciated.

Regards,
-Jim

Please sign in to leave a comment.