Unable to transfer files to EC2 via SFTP

I have my server running on EC2 instances. I can connect to this instance via sftp ubuntu@{instance information} and this does not require a password because the details are in the .ssh .pem file. However there is no way to specify a .pem file for IntelliJ, nor is there a way to get IntelliJ to invoke the command line sftp ubuntu@{instance information}. When trying this with the instance info in the sftp host, the user name set to ubuntu, the auth type as password and the password empty - it fails all the time. Stuck and don't know where to turn next.

4 comments
Comment actions Permalink

Hello Gregory,

As far as I understand the problem, you have to convert your PEM file to OpenSSH keypair (e.g. 'foo.pem' will produce 'foo' and 'foo.pub' files) and specify 'foo' file location in 'Private key file' field. Also please watch/vote related feature request: http://youtrack.jetbrains.net/issue/WI-1106.

Regards,
Kirill

0
Comment actions Permalink

Hi Gregory,

I was able to use Deployment with EC2 and SFTP by creating public key using command 'ssh-keygen -y -f mykey.pem > mykey.pem.pub' and setting 'Private Key file:' to mykey.pem. Just make sure that mykey.pem and mykey.pem.pub are in the same directory.

Cheers,
Shmel.

0
Comment actions Permalink

I tried "ssh-keygen -y -f mykey.pem > mykey.pem.pub" and "puttygen mykey.pem -o mykey.ppk" but intellij is not accepting these files. 

0
Comment actions Permalink

Avasthiarman, is there any kind of error message? Generally, PuTTY keys are working just fine.

0

Please sign in to leave a comment.