Odd beginning of line behavior

I don't know if this is a new configuration option that I've missed or simply a bug, but I'm having real trouble keeping the editor cursor where it should be.

If the cursor is ever on a new line in an indented position, and then I alt-tab away from intellij, when I come back the cursor is no longer in the indented position, but instead it's at the true beginning of the line all the way to left. It's incredibly annoying. I leave the cursor in one place, but when I come back, it's in another. This only happens on a new empty line.

Is there any way to make this behave the way it used to? The way it seems like it intuitively should?


Ok, after writing the above I went and had one last look. I had turned off the setting to "allow placement of caret after end of line" in the settings. When I turn this back on, the cursor stays in position after returning from an alt-tab. However, in Intellij 9 the cursor stayed where it was suppose to regardless of whether this setting is on or off (I loaded up 9 just to to test it and be sure).

So, I guess this is a bug. Is there a way to officially report this?


My suspicion, is that it is actually a combination of the "Strip [All] trailing spaces on Save" setting and the "Save files on frame deactivation" setting. So when you navigate away from IDEA, it is saving. As part of that save, it strips trailing spaces. On a blank line, trail spaces == leading spaces.So if you turn off on of those options, it would resolve your issue.

See http://devnet.jetbrains.net/message/5273323 for a discussion on a similar manifestation of this behavior.

If you want a change in the behavior, you can file a change request at http://youtrack.jetbrains.net. A possible solution might be add an additional option as to whether to treat spaces on a blank line as trailing spaces or leading spaces.


denis.zhdanov wrote:

Hi Matthew,



Fantastic. Thanks for pointing this out. I'll know where to look for things like this in the future.



Please sign in to leave a comment.