Errors using modules linked to eclipse

I linked a few eclipse projects to IJ projects. This was working for a bit - even seeing updates to the eclipse projects.

But when i try to restart IJ it complains "Could not save project Unsupported classpath format eclipse".

This is a real problem because it is not up to me about how the company builds its projects - they have eclipse-only plug-ins. So I need to be able to work with eclipse.



Attachment(s):
IJEclipseError.JPG
4 comments
Comment actions Permalink

Hello Stephen,

Please make sure that the Eclipse plugin is enabled in Settings | Plugins.

I linked a few eclipse projects to IJ projects. This was working for a
bit - even seeing updates to the eclipse projects.

But when i try to restart IJ it complains "Could not save project
Unsupported classpath format eclipse".

This is a real problem because it is not up to me about how the
company builds its projects - they have eclipse-only plug-ins. So I
need to be able to work with eclipse.

---
Original message URL:
http://devnet.jetbrains.net/message/5281566#5281566


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

thanks for pointing that out.  I am unable to go into the project settings because the project explorer just says "Loading" .. it hangs there.  It also brings up that error dialog "Unsupported project format eclipse" time after time.  So I am unable to go into the settings to enable the eclipse plugin.

How would I do that via an ascii editor ?

BTW I see that the disabled_plugins.txt file contains org.jetbrains.idea.eclipse  and I did not do that.. it happened itself looks like.  I have commented it out to see what happens..

0
Comment actions Permalink

Hello Stephen,

The disabled_plugins.txt file doesn't support comments - the plugin ID should
be removed entirely.

It may be possible that you clicked the "Disable plugin" button after some
exception occurred in the Eclipse plugin.

thanks for pointing that out.  I am unable to go into the project
settings because the project explorer just says "Loading" .. it hangs
there.  It also brings up that error dialog "Unsupported project
format eclipse" time after time.  So I am unable to go into the
settings to enable the eclipse plugin.

How would I do that via an ascii editor ?

BTW I see that the disabled_plugins.txt file contains
*org.jetbrains.idea.eclipse * and I did not do that.. it happened
itself looks like.  I have commented it out to see what happens..


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

after having commented out in the disabled_plugins.txt as stated IJ did come up and eclipse integration was working again.  interesting.   i'm a happier camper again.

0

Please sign in to leave a comment.