Appearance

Hi,

i need your help.
The menupoint 'Appearance' in the IDE-Settings don't work. When i klick
this menupoit the idea close. Ther is no error message.

Please help me, i am very desponded.

--
Greetings from Germany
Roland Kruggel

8 comments
Comment actions Permalink

Roland Kruggel wrote:

Hi,

i need your help.
The menupoint 'Appearance' in the IDE-Settings don't work. When i
klick this menupoit the idea close. Ther is no error message.


Sorry, i forgot.
My System is Debian Linux sid. (also in woody)
Kernel 2.6.1 or 2.4.23
Idea Build 1126.
The mistake is sins build 992 or so. I don't remember i exect
buildnumber.

--
Greetings from Germany
Roland Kruggel

0
Comment actions Permalink

Please submit a request into the tracker and attach your idea.log file
(right after it closes).

--
Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

"Roland Kruggel" <rk-liste@gmx.de> wrote in message
news:bv91di$561$1@is.intellij.net...

Hi,

>

i need your help.
The menupoint 'Appearance' in the IDE-Settings don't work. When i klick
this menupoit the idea close. Ther is no error message.

>

Please help me, i am very desponded.

>

--
Greetings from Germany
Roland Kruggel



0
Comment actions Permalink

FWIW this works for me on Red Hat 9 + 2.6.1 kernel, build 1126. I see
no problems at all in that dialog.

Nick.

Roland Kruggel wrote:

Roland Kruggel wrote:

>>Hi,
>>
>>i need your help.
>>The menupoint 'Appearance' in the IDE-Settings don't work. When i
>>klick this menupoit the idea close. Ther is no error message.


Sorry, i forgot.
My System is Debian Linux sid. (also in woody)
Kernel 2.6.1 or 2.4.23
Idea Build 1126.
The mistake is sins build 992 or so. I don't remember i exect
buildnumber.

0
Comment actions Permalink

I have had the same issue since the first 4.5 release.
Before and during this time I have been using Debian "unstable" (sid) with various 2.6 kernels.

I have observed the problem with the bundled JVM, and my own 1.4.2 and 1.5.0 JVMs.

The problem also exists when using a 64-bit 1.4.2 or 1.5.0 JVM on my AMD Pure64 Debian machine.

The idea.log contains no trace of the crash.

I just avoided the "Appearance" section until now, but with the new ugly Alloy look and feel being the default in the latest Irida build this has become an irritation.

0
Comment actions Permalink

I also had this problem with IDEA and Debian Sid. If I started IDEA in a console I could see that the JVM died with some assertion in a native C file (something about fonts I think).

Upgrading to 1.5.0 fixed the problem for me, but that caused some other problems.
Recently I installed JDK 1.4.2 from Blackdown, and IDEA seems to work fine with that, and I can access the Appearance menu!
I think Blackdown has a 1.4.2 JDK for AMD64, maybe you can try that?

0
Comment actions Permalink

Any JDK prior to 1.5 chokes on some fonts that are installed by default on Sid. Solaris also has this same problem.

Unfortunately I can't remember which fonts makes the JDK choke right now. You may want to try uninstalling some true type fonts, one at a time, till you find the offending font, and then share your findings with us :)

0
Comment actions Permalink

I'm using Sun JDK 1.5.0 and it crashes.
Prior to 1.5 I ONLY used the BlackDown Java ports, and the fault occurred with both.

0
Comment actions Permalink

Update:

Using the latest Blackdown 1.4.2 there is no problem.

0

Please sign in to leave a comment.