4.5.2 & 4.5.3 crashing

Installed irda this morning...tested a little...way to unstable...go back to my 4.5.2 and now i'm getting seemingly random crashes (jvm crash). Something to do with the native filewatcher i think.

Up until yesterday i could leave 4.5.2 running for days...now even if i'm not using it it just disapears. I have tried upgrading to 4.5.3 and uninstalling irda.

I hope anyone has any ideas. Please.
I'm on WindowsXP
Here is the crash file i find in the intelli bin dir:

6 comments

You probably installed Irida pointing to the same config and system directories as Pallada. Try removing your ~/.IntelliJIdea/system directory before running Pallada.

0

What makes me think... JetBrains, how about making that the default for EAP builds?

Storing system and config directories on ~/.IntelliJIdea-Irida or something like that by default would prevent a lot of bug reports agains both Irida and Pallada.

0

Good tip, unfortunately i never let an EAP install to the "recommended" location and instead, tell it to write them into its own install dir.

Nevertheless i tried your advice, and ....it crashed again after a few mins once i'd opened my project and left it completely alone...

This is very frustraing!
The only thing i can think of that has changed is i installed the latest version of TortoiseSVN which i use to update/commit my project....it fiddles with the source files that idea is using. Never been a problem up until this week.

Hope anyone has any ideas.
oliver

0

Did you instal Irida over the 4.5.2 or into separate directory?


--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Yes. I try to keep EAPs totally seperate (incl. system and config)

-intellij
- 4.5.2
- 4.5.3
-irda
- 3144
- etc

In the meantime i've found out that it is related to jboss. In fact it is related to the name of a jboss configuration.
Here is what i have observed:


Other observations:
-If i rename the jboss configuration dir to say "pv" then there is no problem.

-Deploying/Undeploying any other applications deployed in jboss do not cause any problems

- removing FileWatcher2K.dll solves the problem

- this problem is briefly mentioned in
http://www.intellij.net/forums/thread.jsp?forum=22&thread=51047&message=638906&q=46696c6557617463686572324b2e646c6c#638906

0

Hello.

Any news on this?
Any more info i can post on this.
I would like to have FileWatcher2K.dll enabled...faster than the fall-back solution.

Should the native code not just scan the intellij project related directories? Why is it affected by something happening in a totally unrelated directory (in my case jboss deploy dir)?

cheers
oliver

0

Please sign in to leave a comment.