Is Android Plugin Deprecated in IDEA X (10.0)?

The website for the IDEA-Android plugin says this:

http://code.google.com/p/idea-android/

"The Android support is now a bundled feature of IntelliJ IDEA 9 Ultimate. The open-source version of the plugin available at this site is outdated and incompatible with IntelliJ IDEA 9."

Does this mean that we should DELETE the Android 1.0.2 plugin if we are using IDEA 9.x or IDEA 10.x, in favor of the "built in" support?  The Android functionality I'm trying to use doesn't seem to be working, and I'm wondering if it's running the deprecated plugin instead of using the new "built in" Android logic?

- Eric

3 comments
Comment actions Permalink

Hello Eric,

Indeed, you should delete the separately installed plugin. We'll advance
the built-in plugin version to make sure that it takes over the separately
installed plugin automatically.

The website for the IDEA-Android plugin says this:

http://code.google.com/p/idea-android/

"The Android support is now a bundled feature of IntelliJ IDEA 9
Ultimate. The open-source version of the plugin available at this site
is outdated and incompatible with IntelliJ IDEA 9."

Does this mean that we should DELETE the Android 1.0.2 plugin if we
are using IDEA 9.x or IDEA 10.x, in favor of the "built in" support?
The Android functionality I'm trying to use doesn't seem to be
working, and I'm wondering if it's running the deprecated plugin
instead of using the new "built in" Android logic?


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi Dimitry,

I'm still a bit confused.  When I go into the plugins, I see:

Android Support.  Version 1.0.2.

I cannot delete this plugin (it won't allow me to delete, only disable).  I am running IDEA X.  Is 1.0.2 the latest version of the Android plugin?

My original question simply asked, do we even need an Android plugin anymore, or is the Android support "built-in" to the application without the need for a separate plugin in the list of plugins?

- Eric

0
Comment actions Permalink

Hello Eric H.,

The Android support is a bundled plugin; it is visible in the list of the
installed plugins. We weren't advancing the plugin version number when the
plugin became bundled, so 1.0.2 can indicate both the bundled plugin as of
previous EAP build, and the separately installed plugin.

I'm still a bit confused.  When I go into the plugins, I see:

Android Support.  Version 1.0.2.

I cannot delete this plugin (it won't allow me to delete, only
disable).  I am running IDEA X.  Is 1.0.2 the latest version of the
Android plugin?

My original question simply asked, do we even need an Android plugin
anymore, or is the Android support "built-in" to the application
without the need for a separate plugin in the list of plugins?


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.