Inspecting output directories...

In the past it wasn't like this, but now it is: Whenever debugging a Java program with IntelliJ, there is a background process "Inspecting output directories..." that hangs for 10 seconds, and only then the program starts.

This happens all the time, even when not changing any java code at all, and even when running the process multiple times in a row without changing any source in between (so it's compiled for sure).

In the past, when using IntelliJ, when I changed some Java code and debugged a program, there was some delay due to the recompiling and such. But now there's always a delay, due to this thing.

What could cause this, and how could I disable that cause?

The IntelliJ version is 9.0.1 Ultimate.

Thanks!

EDIT: I checked in the background processes dialog: The process that says "Inspecting output directories..." is called "Make". But this doesn't help me any further, why would it make anything when I don't change the source code?

7 comments

Hello Aardwolf,

Please try to close IDEA, delete settings\compiler\paths_to_delete.dat and
restart IDEA. This should help.

In the past it wasn't like this, but now it is: Whenever debugging a
Java program with IntelliJ, there is a background process "Inspecting
output directories..." that hangs for 10 seconds, and only then the
program starts.

This happens all the time, even when not changing any java code at
all!

In the past, when using IntelliJ, when I changed some Java code and
debugged a program, there was some delay due to the recompiling and
such. But now there's always a delay, due to this thing.

What could cause this, and how could I disable that cause?

Thanks!

---
Original message URL:
http://www.jetbrains.net/devnet/message/5258708#5258708

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

That helped! It goes as fast as in the past again. I think I can still see the text "Inspecting output directories" appearing but it goes so fast that it's hardly noticable now. Thanks!

0

Thanks for this - sorted my problems out (and I think it stopped the weird constant refresh icon in the project window too).

On mac the file is ~/Library/Caches/IntelliJIdea90/compiler/paths_to_delete.dat

0

Worked for me too! Thanx!

On linux: ~/.IntelliJIdea90/system/compiler/paths_to_delete.dat

0

Well it helps but the annoying thing is that every few weeks it starts happening again, it feels like I sort of have to manually clean up the garbage every few weeks... :)

0

Hi Dmitry,

It helped for a while, but now it takes a long time again and the file is missing (I only deleted it once). Is there something else that I can do?

Thanx!
Rob.

0

Apparantly you als have to recreate it as an empty file on linux.

0

Please sign in to leave a comment.