Awkwardness with step debugging

I'm using irida build 3144 to debug a simple Xerces-SAX based application. The debugger always stepped into some xerces's classes, like org.apache.xerces.parser.AbstractSAXParser.
I also tried to add a pattern "org.apache.*" in debugger setting, but got no help.
Any solution for this?
Thanks.

4 comments

I haven't tried it, but suggest the following:

Try using the full package name like 'org.apache.xerces.parser' in the 'Do not step' settings.

0

Note that class pattern is matched against the qualified name of object concrete type.
So if the implementation of AbstractSAXParser lives in the package whose qualified name does not start from "org.apache", the filter
won't work.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Is there any setting to block the debugger to step into any library classes ?

0

You can configure step filters in Debugger Settings.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Hu Bo" <webmaster@lanhei.com> wrote in message news:17172702.1103897378935.JavaMail.itn@is.intellij.net...

Is there any setting to block the debugger to step into any library classes ?



0

Please sign in to leave a comment.