compiler target and module language level problem

Hello,

i have an issue with the java compiler on intellij, 9.0.3, on osx.

I go into preferences, compiler and change the default "-target 1.5" to "target 1.6", and i set the language level to 6.0 on all my modules.

Now, every now and then, these settings are reset to 1.5 in the java compiler, and 5.0 in the language level, seemingly for no apparent reason.


This is very frustrating, does anybody know if this can be prevented?

Please sign in to leave a comment.