IdeaX compatible Jetty Plugin?

I tried the Jetty plugin with IDEA X. Got several exceptions and I don't
think that it deployed my application.

Is support for IDEA X in the works, or even on the radar?

Thank you,

Donald

4 comments

Hi Donald,

A while back I updated the plugin to support Jetty 7, and Mark Scott (the
plugin author) released a new version incorporating some of my changes. A
similar thing happened for IDEA 9 support; Peter Niederwieser made the required
changes and Mark picked those up too. So I'd suggest that if you really want
it, you grab the code from http://github.com/codebrewer/intellij-idea-jetty-integration-plugin
and have a go at fixing the problems yourself then supplying the patches
to Mark. My experience was that it wasn't very hard to make the required
changes, hopefully IDEA 10 support shouldn't be hard to add either. Failing
that, you'll probably have to wait until someone else gets around to updating
it, which might take a while (I personally aren't likely to do it since I'm
not doing any web dev these days).

Chris

PS: You're probably better off posting this sort of question to the plugin
list since it's a 3rd party plugin that's not officialy supported by JetBrains.

I tried the Jetty plugin with IDEA X. Got several exceptions and I
don't think that it deployed my application.

Is support for IDEA X in the works, or even on the radar?

Thank you,

Donald



0

Hi Chris,

On Fri, 17 Sep 2010 14:24:05 +0000, Chris Miller wrote:

A while back I updated the plugin to support Jetty 7, and Mark Scott
(the plugin author) released a new version incorporating some of my
changes.


Only some?  :(   I recall doing some refactoring to take advantage of
IDEA's extensions framework - did some functionality you added get
overlooked in the process?

--
Mark Scott
mark@codebrewer.com

0

Hi Donald,

On Fri, 17 Sep 2010 09:20:08 -0400, Donald Mclean wrote:

I tried the Jetty plugin with IDEA X. Got several exceptions and I don't
think that it deployed my application.

Is support for IDEA X in the works, or even on the radar?


The plug-in did work with IU-96.802 but it seems there have been OpenAPI
changes since then that cause the exceptions you saw.

I've updated the plug-in for IU-96.1190 and a new build is available for
download via IDEA's plug-in manager.

--
Mark Scott
mark@codebrewer.com

0

Hi Mark,

Only some?  :(   I recall doing some refactoring to take advantage of
IDEA's extensions framework - did some functionality you added get
overlooked in the process?


Sorry Mark I didn't mean to imply that you'd missed anything out, more like
what you said - you'd taken the hacks I'd made and improved them in your
official release :)

Chris


0

Please sign in to leave a comment.