UI Designer, JIDE and VM parameters

Hi

I am pretty new to IntelliJ, and am trying to use the JIDE widget library in the UI designer. It all works well, but when I compile my form I am guessing that IntelliJ actually tries to instantiate the relavent bound class. Can anyone confirm this? The reason I think so is that on a compile, the JIDE license dialog pops up, which only happens when you try to instantiate a JIDE component without a license key.

So I guess my real question is how do I get access to the VM that executes, so I can add my own parameters .. for JIDE licensing? It should also be a solution for the Ant Build version. If I use Build->Generate Ant Build on the project, and then use the resulting script, I get the same popup when doing a compile. Looking at the Ant xml, I can't see anywhere to set VM parameters.

Thanks
Jon

1 comment

Hello jon,

Yes, IntelliJ IDEA does instantiate the components. If you use Make from
IntelliiJ IDEA, it instantiates the components in its own JVM, so you can
define the JIDE licensing parameters in idea.properties or idea.exe.vmoptions
in the IntelliJ IDEA installation directory. When using Ant, the form instrumentation
is by default performed in the same process as the Ant script execution,
so you can define the VM options in the Ant command line.

I am pretty new to IntelliJ, and am trying to use the JIDE widget

library in the UI designer. It all works well, but when I compile my
form I am guessing that IntelliJ actually tries to instantiate the
relavent bound class. Can anyone confirm this? The reason I think so
is that on a compile, the JIDE license dialog pops up, which only
happens when you try to instantiate a JIDE component without a license
key.

So I guess my real question is how do I get access to the VM that
executes, so I can add my own parameters .. for JIDE licensing? It
should also be a solution for the Ant Build version. If I use
Build->Generate Ant Build on the project, and then use the resulting
script, I get the same popup when doing a compile. Looking at the Ant
xml, I can't see anywhere to set VM parameters.

Thanks
Jon
---
Original message URL:
http://devnet.jetbrains.net/message/5272209#5272209


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.