IDEA cannot resolve FacetTypeFrameworkSupportProvider

Hi,

I am working on a new plugin and I want to Facet-enable it. However IDEA cannot resolve the FacetTypeFrameworkSupportProvider class. In fact, looks like the com.intellij.facet.impl package is not resolvable at all.

Any ideas what do I have to do to fix this problem?

Cheers,
Behrang

1 comment

FrameworkSupportProvider staff was moved to open api in IDEA 9. The class mentioned by you was renamed to
com.intellij.facet.ui.FacetBasedFrameworkSupportProvider

Hi,

>

I am working on a new plugin and I want to Facet-enable it. However IDEA cannot resolve the FacetTypeFrameworkSupportProvider class. In fact, looks like the com.intellij.facet.impl package is not resolvable at all.

>

Any ideas what do I have to do to fix this problem?

>

Cheers,
Behrang

>

---
Original message URL: http://devnet.jetbrains.net/message/5272188#5272188



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.