IntelliJ (v4.5.3 and build #3075) and Ant problems

Hi

I have several problems running Ant from IntelliJ, hope you can help me.

I have tried from commandline and from IntellIJ, and all problems listed below is only occurring inside IntelliJ (tired v4.5.3 and build #3075)..

1) If i run Ant with options "-verbose" and "-debug" the output is not the same in IntelliJ as on commandline??

2) When running an Ant target some .jar files is added to the classpath (seen in the message output screen) that is not configured in the project/module or even defined in the environment classpath??? These .jar files is of my creation from old projects (IntelliJ v3.0.5), but have absolutely no relations to my current project?! I have looked in all project/module files, but the files are not listed anywhere. The .jar files exist on the project drive though...

3) When using BEA clientgen target in Ant i got a Ant exception saying "IncompatibleClassChangeError", this works on commandline?? This error can have some relation to 2)??

Thanks to anyone who can help :)

Cheers Frank

1 comment

After some further research i found the solution to problem 2)

The external .jar files where located under the jdk libraries (found in jdk.table.xml)??? I have never edited or manually configured the jdk libraries, so i have no clue on how they ended there..

Problem 1) still remains...

0

Please sign in to leave a comment.