How to disable svn annotate merges processing?

On Maia to svn plugin was added possibility to mark merge commits in file annotation. After this addition annotate function began to work much slower(3-4 times) on files with merges in history.
I think annotate work slower because it somehow process all merge commits. This feature sometimes is not useful for me, and I want to disable it, but I don't know how.
In IDE Settings->Version Control->VCSs->Subversion I turn off "Show merge source in annotations by default", but this has no effect on annotate showing speed, and it still show "M" on merges.
Can I disable this function, or increase "annotate" showing speed?

Thanks

2 comments

In IDEA X (I'm not sure about Maia, please try), Settings | Version Control | VCSs | Subversion -> Show merge source in annotations

0

Oh, how could I not guess that IDEA X have this possibility. Maia does not.
Since svn4idea is opensource(as many other good plugins) I get it sources and manually added this feature(my patch very similar to your commit a3433705). I rebuild plugin and now use it in my Maia :).
Thank you very much Irina, in the future I will look into EAP before "reinvent the wheel":).

0

Please sign in to leave a comment.