JavaME project, ClassFormatError: Bad version information

Hi all.
I've been trying to run a JavaME hello world MIDlet from Intellij. The phone emulator starts up fine, but whenever I press the button to launch the MIDlet the phone closes and Intellij prints "ALERT: java/lang/ClassFormatError: Bad version information.".
I have Sun Wireless Toolkit 2.5.2 installed and am using Intellij 9.0.3 - Intellij doesn't seem to support the newer JavaME SDK 3.0 and won't even start the emulator with that version.

What to do?

Please sign in to leave a comment.