UnsupportedClassVersionError in build 3084

Hi,

My earlier version(4.5) of IDEA my project works fine but i'm getting following problem in build 3084. i feel this build is not take project jdk to compile. am i right?

Information: 1 error
Information: 0 warnings
Information: java.lang.UnsupportedClassVersionError: com/intellij/rt/compiler/JavacRunner (Unsupported major.minor version 47.0)
Information: at java.lang.ClassLoader.defineClass0(Native Method)
Information: at java.lang.ClassLoader.defineClass(ClassLoader.java:471)
Information: at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:103)
Information: at java.net.URLClassLoader.defineClass(URLClassLoader.java:242)
Information: at java.net.URLClassLoader.access$1(URLClassLoader.java:210)
Information: at java.net.URLClassLoader$1.run(URLClassLoader.java:191)
Information: at java.security.AccessController.doPrivileged(Native Method)
Information: at java.net.URLClassLoader.findClass(URLClassLoader.java:185)
Information: at java.lang.ClassLoader.loadClass(ClassLoader.java:292)
Information: at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:279)
Information: at java.lang.ClassLoader.loadClass(ClassLoader.java:249)
Information: at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:308)
Information: Exception in thread "main"
Error: Compiler internal error. Process terminated with exit code 1
Information: Compilation completed with 1 errors and 0 warnings

2 comments

This should be fixed in build 3089. Does it work for you?

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"



0

Thanks Eugene Zhuravlev. Its working now.

0

Please sign in to leave a comment.