Numpad "delete" key

Hi everybody ! I'musing a french keyboard on linux with Java 6 adn of course IDEA 7. When I attempt to use the "dot" key on the numpad in IDEA ( or another java program) It seems to send the two keycode , the "." and the "delete".

Is anybody have a solution ?

Thanks in advance., YB

4 comments
Comment actions Permalink

Hi Yann (it's small world my friend) !

Today, I had  the same problem on Ubuntu (you have certainly found a solution to this  old problem). By default, when you install Ubuntu, French keyboard is  defined to 'France Autre". This option isn't manage correctly by our  favourite IDE because the "dot" key of the numpad is mapped to the same  key than the "delete" key (other applications manage correctly the "dot" key...).
To  correct (or by-pass) this problem, you have to change the French  keyboard option to "France" then the "dot" key will have the good  behaviour.

Hope it helps a lot of French guys !
Olivier Catteau

0
Comment actions Permalink

If it does not work correctly in IDEA, then most likely it is a Java
problem, not IDEA's. On a German keyboard the numpad comma also can be the
delete key -- if num is not selected.

0
Comment actions Permalink

I have the same behaviour than you if numlock isn't active. It's strange but it isn't cumbersome for me...

0
Comment actions Permalink

Hi.

Maybe some hints from here can help: http://youtrack.jetbrains.net/issue/WI-2519
(I did not try them, for me it works Ok).

Regards,
Alexander.

0

Please sign in to leave a comment.