Suspicious JRE bundled with 4.5.2 2244

4.5.2 (http://download.jetbrains.com/idea/idea-4.5.2.zip) ships with
a suspicious windows JRE: all the files come from jre 1.4.2_04 except
for most DLLs that come from jre 1.4.2_03 (the jvm client DLL itself
comes from jre 1.4.2_04). That leads 'java -version' and 'java -fullversion'
to report different version numbers.

Any reason why the bundled jre has mix-matched files? I find it a little
surprising (but that's about it, not a big issue).

I already reported the issue for 2239:
http://www.intellij.net/forums/thread.jsp?forum=22&thread=106729&message=337
5279&q=76696e6365206a7265#3375279

Vince.


Please sign in to leave a comment.