freemarker support

I'm not very familiar with freemarker so I might be doing something wrong. I need to modify one of the freemarker templates included with Struts2. The first thing I noticed was freemarker templates with .ftl extension were not associated with Velocity templates so I added it. Unfortunately, when it try to edit the file in the editor, Intellij flags almost the whole file as an error. Is there anything I can do to improve the situation beyond disabling all inspections? I attached a screenshot.



Attachment(s):
freemarkerErrors.png
5 comments
Comment actions Permalink

Hello,

FreeMarker is not the same thing as Velocity. Please associate the extension
with the correct file type.

I'm not very familiar with freemarker so I might be doing something
wrong. I need to modify one of the freemarker templates included with
Struts2. The first thing I noticed was freemarker templates with .ftl
extension were not associated with Velocity templates so I added it.
Unfortunately, when it try to edit the file in the editor, Intellij
flags almost the whole file as an error. Is there anything I can do to
improve the situation beyond disabling all inspections? I attached a
screenshot.

---
Original message URL:
http://devnet.jetbrains.net/message/5267509#5267509

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

.ftl files should be associated with Freemarker, while .vm files should be associated with Velocity.
Freemarker and Velocity are two totally separate templating systems, with different syntax rules.

0
Comment actions Permalink

I realize Velocity and Freemarker are different but the current EAP has .ft files associated to Velocity template files and Freemarker is not one of the recognized file types so what exactly am I supposed to do to get Intellij to recognize them? I've used Velocity for years so I understand the difference.

NEVERMIND: I had the Freemarker plug-in disabled. Once I enabled it I was able to make the association.

Grant

0
Comment actions Permalink

Hello Grant,

Please make sure you have the FreeMarker plugin enabled in Settings | Plugins.

I realize Velocity and Freemarker are different but the current EAP
has .ft files associated to Velocity template files and Freemarker is
not one of the recognized file types so what exactly am I supposed to
do to get Intellij to recognize them? I've used Velocity for years so
I understand the difference.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks Dmitry,

That was one of my duh moments. I keep a lot of plug-ins disabled when I don't need them to boost performance. I never used Freemarker before so I had it disabled. After I posted my previous comment I realized the plug-in was disabled. Thanks for the reminder.

Grant

0

Please sign in to leave a comment.