reformat wrapping not working

I am running build 2235. I have had this issue for quite some time now, so it is not specific to his build but has been around a while already.

I have set my wrapping settings in global style options and the preview pane shows everything wrapping as I want it. It used to work too, I don't know which version broke it.

Now when I select the (java source) file contents with ctrla and hitl ctrlalt+l to reformat it, it formats it correctly in every way, except no wrappings are made. This is kinda annoying. Is there something I may have set wrong in the settings or is it possible for some older settings or whatever to mess my wrapping options? Or is this just a bug? Or am I just stupid.. :) ?

OK I just tried again, if I choose "reformat this file" it is formatted correctly. If I choose "reformat selected text" it forgets the wrappings..

1 comment

teemu kanstren wrote:

I am running build 2235. I have had this issue for quite some time now, so it is not specific to his build but has been around a while already.

I have set my wrapping settings in global style options and the preview pane shows everything wrapping as I want it. It used to work too, I don't know which version broke it.

Now when I select the (java source) file contents with ctrla and hitl ctrlalt+l to reformat it, it formats it correctly in every way, except no wrappings are made. This is kinda annoying. Is there something I may have set wrong in the settings or is it possible for some older settings or whatever to mess my wrapping options? Or is this just a bug? Or am I just stupid.. :) ?

OK I just tried again, if I choose "reformat this file" it is formatted correctly. If I choose "reformat selected text" it forgets the wrappings..


That's true indeed. The wrapping only works when reformatting the whole
file and does not work when reformatting a selection. Kind of a missing
or incomplete feature.


--
Maxim Shafirov
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.