Unable to compile (Error)

Hi,

I am able to compile my project using maven, both from command line and inside idea. But when I use Idea to compile I get the following error:

Error: Read from storage 0 bytes, but requested 12 bytes.

This could have something to do with a recent hard shutdown of my computer, perhaps something on the file system is damaged? But if that is the case, I don't understand why maven is unaffected, while Idea fails. Does Ideas compiler read some file before compiling?


Maven and Idea uses the same JDK:

pow@lilou /home/pow/Skrivbord % java -version
java version "1.6.0_15"
Java(TM) SE Runtime Environment (build 1.6.0_15-b03)
Java HotSpot(TM) 64-Bit Server VM (build 14.1-b02, mixed mode)


I'm using linux (xubuntu 9.10 - 64-bit) . Idea.vmoptions below:
pow@lilou /home/pow/Program/idea-IU-90.193/bin % cat idea.vmoptions
-Xms64m
-Xmx1024m
-XX:MaxPermSize=300m
-ea


Any ideas?

4 comments
Comment actions Permalink

Hello Per-Olof,

Please use File | Invalidate Caches and restart IntelliJ IDEA. This should
fix the problem.

I am able to compile my project using maven, both from command line
and inside idea. But when I use Idea to compile I get the following
error:

Error: Read from storage 0 bytes, but requested 12 bytes.

This could have something to do with a recent hard shutdown of my
computer, perhaps something on the file system is damaged? But if that
is the case, I don't understand why maven is unaffected, while Idea
fails. Does Ideas compiler read some file before compiling?

Maven and Idea uses the same JDK:

pow@lilou /home/pow/Skrivbord % java -version
java version "1.6.0_15"
Java(TM) SE Runtime Environment (build 1.6.0_15-b03)
Java HotSpot(TM) 64-Bit Server VM (build 14.1-b02, mixed mode)
I'm using linux (xubuntu 9.10 - 64-bit) . Idea.vmoptions below:
pow@lilou /home/pow/Program/idea-IU-90.193/bin % cat idea.vmoptions
-Xms64m
-Xmx1024m
-XX:MaxPermSize=300m
-ea
Any ideas?

---
Original message URL:
http://www.jetbrains.net/devnet/message/5251784#5251784

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks Dmitry,

I don't know if that helped, but I think it would have, I will remember this for future use.

Before I read your anserw I had already removed the files in .IntelliJIdea90/system, and it worked after that, but I assume that your suggestion is a less drastic approach.

For the record: I don't belive that Idea caused this, as I had some other problems earlier with files that were damaged (because of some unidentified hardware issue).

thanks

0
Comment actions Permalink

If you have this problem, I suggest doing as suggested by Dmitry. If that don't work, do as I did.

0
Comment actions Permalink

I know this is old, but just FYI, when I encountered the problem recently, I resolved it by deleting the compiler cache (on Windows, Documents and Settings\user\.IntelliJIdea90\system\compiler).

0

Please sign in to leave a comment.