Modified without checkout: Perforce

Hi,

Intellij displays few files as "modified without checkout". I've enabled 'Show Clear Read-Only Status dialog box', and intellij displays alert box whenever I try to modify the source file, I select modify using version control option.
Few times I observed that my perforce tickets gets expired and intellij shows a warning message and it goes ahead and clears read-only status of the file. I dont want intellij to clear the read-only status without checking out the file from perforce. Is there a way to enforce this?

I am using Intellij 9.0 (95.66) and perforce is the version control system.

Thanks,
Chandra

1 comment
Comment actions Permalink

Hello chandra,

Please turn off Settings | Version Control | Background | Perform Edit/Checkout
in background. In this case IDEA will always perform a checkout operation
under a modal progress dialog and will not clear the read-only status by
itself.

Intellij displays few files as "modified without checkout". I've
enabled 'Show Clear Read-Only Status dialog box', and intellij
displays alert box whenever I try to modify the source file, I select
modify using version control option.

Few times I observed that my perforce tickets gets expired and
intellij shows a warning message and it goes ahead and clears
read-only status of the file. I dont want intellij to clear the
read-only status without checking out the file from perforce. Is there
a way to enforce this?

I am using Intellij 9.0 (95.66) and perforce is the version control
system.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.