Update Resouces on Frame deactivation

Hi,
I am running Intellij 94.192 on Windows 7 64 bit if I select the button for updating resouces on frame deactivation in the run window it doe's not work. Although the button just for update works fine and redeploys the app.


Cheers Martyn

8 comments
Comment actions Permalink

Which type of run configuration do you use?
What message is shown in the status bar when you switch from IDEA? "Compilation completed", "All files are up-to-date" or something else?

Hi,
I am running Intellij 94.192 on Windows 7 64 bit if I select the button for updating resouces on frame deactivation in the run window it doe's not work. Although the button just for update works fine and redeploys the app.


Cheers Martyn

---
Original message URL: http://www.jetbrains.net/devnet/message/5255732#5255732



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Hi Nikolay,
I am just using intellij default configuration and when I click outside of intellij I don't get a message or update at all in the status bar resulting  in no files being updated on the server.

0
Comment actions Permalink

I just noticed that on configuring a new server using glassfish the option in the run/debug window for update resources is available once checked it disapears and does not update on frame deactivation.

0
Comment actions Permalink

Hi all,
I am using the latest MEP version of Intellij and this feature still does not work for me on windows 7 64bit. I still have to manually update the files on the server does anyone else suffer from the same problem?

regards Martyn

0
Comment actions Permalink

Yes, I have the same problem (Windows XP, IntelliJ 9.0.2, jetty-integration plugin, Tapestry5 app) - nothing happens on frame deactivation, the only way to update the app is to press Update or Ctrl-F10.

0
Comment actions Permalink

Well it's been a while since I checked this post so the early releases have moved on a bit but I'm disapointed to see I still have the same problem with update resources on frame deactivation on windows 7 64bit, is there a solutions to this feature? at least one person seems to have the same problem.

Martyn

0
Comment actions Permalink

Ok it seems that to use this feature you have to configure your artifact as web application: Exploded and not war. Every thing works as expected now :-)

0
Comment actions Permalink

I only get the choice between module:war and module:war exploded and I've always used :war exploded - is that the same that you are using, or is it possible to configure module:exploded?

0

Please sign in to leave a comment.