Rename with search & replace: not fun...

Having to approach a simple rename as 10 years ago sucks. Having to do that because the latest IDEA bugfix release shipped with unreliable rename refactoring is even more annoying... :-(

These are 2 tickets I know of. They're marked as normal with no (visible) feedback from JetBrains, other than being assigned.

I also submitted tons of error reports during the EAP related to this issue (or family of issues, because there's more than one thing that's busted). By the looks of it I'm not alone in experiencing difficulties with various refactorings. My log files are full of "java.lang.IndexOutOfBoundsException: Wrong offset: 20876; count:20873" entries.

Since most of the later EAP builds were plagued by these exceptions (at least for me) and you shipped without fixing them, it means you considered them isolated incidents. If so, could you provide some more information as to what's "expected" to not work, what triggers this and what other things get busted once these exceptions start flowing?


1 comment

I've also had trouble with renaming in 9.0 and 9.0.2. I had a project where I tried to do a rename package refactoring in 9.0. This worked on the package itself, but did not propagate to sub-packages and sub-classes. I downloaded and installed 9.0.2. to see if this fixed the problem; but it still didn't work. (Among other things, I tried invalidating caches and reloading, and restarting IntelliJ.) There were no errors in the IntelliJ log at any time.

I created a toy project to see if package renaming was broken in general on my machine, or just for that project. Not only did the package rename work in the toy project, but the act of creating the new project has apparently fixed the old one. So okay, it works now, but not the sort of stability I'm looking for in my development environment.

I've been a user (and a fan) of 5.1.2 for years. My experience so far is that 9.0 is a step back, in stability and in performance.



Please sign in to leave a comment.