[Mac] IDEA won't launch browser

Version 9.0 released.

I've been unable to make IDEA launch any browser.  I've done the following:

  • created a Tomcat run/debug configuration and checked the "Open Browser" checkbox
  • specified the correct start page
  • configured Web Browser settings to use the system default (Safari for me)

When I run the configuration, this stuff works fine:

  • the app is built and deployed to Tomcat
  • Tomcat starts running
  • I can manually go to my browser and hit the URL and it works

So why won't IDEA launch the browser like it promises to?  Would really appreciate some help with this if anyone can shed any light.


I had the same problem. Turns out I got my PATH environment variable wrong for gui apps. Tell IDEA to use /usr/bin/open, and things should work.

Good luck!


Did anyone get this working?  We have been trying various forms of open with no success:

/usr/bin/open /Applications/Safari.app/Contents/MacOS/Safari
open -a /Applications/Safari.app/Contents/MacOS/Safari

I've also tried adding Applications/Safari.app/Contents/MacOS/ to my PATH

All we get is "Cannot start browser:...."

This is in 9.0.2.



Try to leave just "/usr/bin/open" in the input field.


Thanks, that works to open the default browser (FireFox).  I would like to specify Safari to be opened though.  



It seems that I am running into this issue: http://youtrack.jetbrains.net/issue/IDEA-51600.  We are trying to set the non default browser to use when launching a URL for flex.

Anyway to up the priority of this bug?



Please sign in to leave a comment.