How to let ctrl+shift+n ignore files in .hg directories?

If I use ctrl+shift+n to list certain files, then it'll also show all files in the .hg directories. That are quite a lot, and are just internal copies of Mercurial of these files, nothing you'd want to edit.

How can I let IntelliJ ignore this directory?

I tried with "Excluded Folders" in the module settings, but that appears to have no effect.

1 comment

Verify that .hg directories are listed in the "Ignore files and folders" listing at the bottom of the File Types settings dialog (IDE Settings | File Types). It should be there by default in the semi-colon delimited list. But it's possible it got removed at some point.

0

Please sign in to leave a comment.