Disabling "import *"

As a matter of style, I don't like to import "<package>.*." When I import everything from within a package, Intellij replaces all of my imports with an "import <package>.*" statement. Is there a way to tell it not to do so?

1 comment

I set a high threshold for wild-card imports.

Settings -> Code Style -> Imports -> "Class count to use import with '*'"


Randall Schulz

0

Please sign in to leave a comment.