HELP!!!!! IntelliJ will not compile files checked out of CVS, but will if I move them

I have some files in a project called AlertNS. I have 3 modules. The
Applayer module has src in /src and test files in /test. For some
reason, IntelliJ does not recognize files in the /src as java files
(e.g. can't compile, can't find via CTRL-N).

If I move these individual source files to another place and designate
it as a source folder, then everything is fine.

There is something in the CVS created folders that IntelliJ is using to
prevent them from being used as java source files.

Can someone PLEASE HELP ME!!!!! :'(

--
Norris Shelton
Sun Certified Java Programmer

10 comments
Comment actions Permalink

Norris, probably a stupid question to somebody with far more experience in IDEA than me, but was your /src directory designated as a source folder in your module settings??

0
Comment actions Permalink

one thing comes to my mind:

if you have a parentfolder called "CVS" then it will
automatically be excluded from the IDEA project ;)

0
Comment actions Permalink

There is a *src *and a *test *directory. The *src *has the true source
files and the *test *directory contains the test source files.

I can see the test source files if I designate them as src or test.
I cannot see the source files as *src *or test files.

If I copy the individual source files (not the directory try) and put
them in another directory tree, they work.

This is really confusing me. It appears to be something with the CVS
folders, but I can't determine what it is.


Norris Shelton
Sun Certified Java Programmer




Rob Bradley wrote:

>Norris, probably a stupid question to somebody with far more experience in IDEA than me, but was your /src directory designated as a source folder in your module settings??

>

0
Comment actions Permalink

My directory structure is as follows:

/AlertNS (project folder)
/AppLayer (module folder) <- can browse source through project
view, but can't see in packages, etc.
/classes
/classesTest
/CVS
/doc

  • /src*

/test
.cvsignore
ANS.jpx
ANS.oif
AppLayer.iml
/CallFlows (module folder) <- works OK
/clsses
/CVS
/src
.cvsignore
ANSCallFlows.jsx (JBuilder project file checked into CVS).
/CVS
/Webroot (module folder) <- works OK
alertns.ipr
alertns.iws
Applayer.iml (java module)
CallFlows.iml (java module)
Webroot.iml (web module)

Norris Shelton
Sun Certified Java Programmer




Michael Damberger wrote:

>one thing comes to my mind:
>
>if you have a parentfolder called "CVS" then it will
>automatically be excluded from the IDEA project ;)
>
>

>

0
Comment actions Permalink

post your .iml and maybe .ipr
- or check yourself for excluded folders:
<excludeFolder ...

or maybe some module setup problem (?!)

0
Comment actions Permalink

Hello Norris,

There is a *src *and a *test *directory. The *src *has the true
source files and the *test *directory contains the test source files.

I can see the test source files if I designate them as src or
test. I cannot see the source files as *src *or test files.

If I copy the individual source files (not the directory try) and put
them in another directory tree, they work.

This is really confusing me. It appears to be something with the CVS
folders, but I can't determine what it is.

Norris Shelton
Sun Certified Java Programmer
Rob Bradley wrote:

>> Norris, probably a stupid question to somebody with far more
>> experience in IDEA than me, but was your /src directory designated as
>> a source folder in your module settings??
>>
Did you assign the src folder as src for some other module? I did this one and could not see that in the previous module but was visible in the new module. Just my 2 cents.

Thanks,
--Venkat.

0
Comment actions Permalink

Looks like it is not there either. I created a project that has nothing
but this *src *tree in it. It could not see it either.

REALLY WEIRD thing. For a second, the new project DID see the *src
*tree, then it went away. I duplicated my steps and deleted the current
module, created another and set it up the same way. No source files.

Something is really flaky here.

Norris Shelton
Sun Certified Java Programmer




Venkat Sonnathi wrote:

>Hello Norris,
>

>
>>There is a *src *and a *test *directory. The *src *has the true
>>source files and the *test *directory contains the test source files.
>>
>>I can see the test source files if I designate them as src or
>>test. I cannot see the source files as *src *or test files.
>>
>>If I copy the individual source files (not the directory try) and put
>>them in another directory tree, they work.
>>
>>This is really confusing me. It appears to be something with the CVS
>>folders, but I can't determine what it is.
>>
>>Norris Shelton
>>Sun Certified Java Programmer
>>Rob Bradley wrote:
>>
>>
>>
>>>Norris, probably a stupid question to somebody with far more
>>>experience in IDEA than me, but was your /src directory designated as
>>>a source folder in your module settings??
>>>
>>>
>>>
>Did you assign the src folder as src for some other module? I did this one and could not see that in the previous module but was visible in the new module. Just my 2 cents.
>
>Thanks,
>--Venkat.

>

0
Comment actions Permalink

I have turned off exclude output directories. No help. Here are ALL of
the IntelliJ files. Applayer is the one with the problem.


Norris Shelton
Sun Certified Java Programmer




Michael Damberger wrote:

>post your .iml and maybe .ipr
>- or check yourself for excluded folders:

<excludeFolder ...

>
>or maybe some module setup problem (?!)

>



Attachment(s):
Webroot.iml
alertns.iws
Applayer.iml
CallFlows.iml
alertns.ipr
0
Comment actions Permalink

Two things came to my mind:
1. Your folder structure has AppLayer dir but module file refers to Applayer.
2. Settings/General/Ignore files and folders.

Number 1 is most probably the cause though.

0
Comment actions Permalink

Who rocks? Venkat rocks. I stumbled upon the problem. I created a
library called ApprissCore. We keep all of your common code on a fsnr
mount. I attached the sources to these.

I kept seeing the files show up when the show libraries button was
pressed. If I removed the button, they went away. They only showed up
in the library portion, not the project source.

I tested by removing the ApprissCore common library from all the modules
and voila. The sources showed up. I edited the library to NOT include
these sources and BAM, everything worked.

This kind of sucks. I would rather this work module, by module. So in
this module, the module source would take precedence over the library
source since they are in common, not the other way around.

Maxim, do you think I should file a bug on this, or is it working as
designed. If working as designed, do you think it is worth filing as a
feature?

Norris Shelton
Sun Certified Java Programmer




Venkat Sonnathi wrote:

>Hello Norris,
>

>
>>There is a *src *and a *test *directory. The *src *has the true
>>source files and the *test *directory contains the test source files.
>>
>>I can see the test source files if I designate them as src or
>>test. I cannot see the source files as *src *or test files.
>>
>>If I copy the individual source files (not the directory try) and put
>>them in another directory tree, they work.
>>
>>This is really confusing me. It appears to be something with the CVS
>>folders, but I can't determine what it is.
>>
>>Norris Shelton
>>Sun Certified Java Programmer
>>Rob Bradley wrote:
>>
>>
>>
>>>Norris, probably a stupid question to somebody with far more
>>>experience in IDEA than me, but was your /src directory designated as
>>>a source folder in your module settings??
>>>
>>>
>>>
>Did you assign the src folder as src for some other module? I did this one and could not see that in the previous module but was visible in the new module. Just my 2 cents.
>
>Thanks,
>--Venkat.

>

0

Please sign in to leave a comment.