yellow popup dialogs on errors

I am using the latest 9.02 release candidate but I think this is occurring in 9.01 too. This question has been asked before but never answered. I personally consider this a bug unless there is some method to dismiss the popup for good. I observe the problem when I have a method call with a bad parameter list after changing the source method signature. As I move my mouse to highlight the bad code and replace it, Intellij pops up a yellow dialog that covers the source restricting me from hightlighting the code. It's very annoying and a productivity killer when making lots of refactorings. The only solution is resorting to the keyboard and stop using the mouse. Is there a workaround, possibly a keyboard shortcut to dismiss the dialog. I don't want to disable the error reporting, just the annoying dialog that won't disappear on its own. Thanks.

3 comments

What OS and Java version are you running on? For me, in 95.4 (9.0.2 RC) on Windows running via Java 1.6.0_18 the warning dialog is below the line (see screenshot). Have you opened a YouTrack bug report on the issue? That's the best way to ensure the issue gets looked at and fixed.

Anyway, hitting the ESC key turns off the dialog for me.  Also, you might want to try to use ctrl+W or Shift + an arrow key to make your selection.

Finally, for the use case you mention, have you tried using the Change Signature refactor action (Ctrl+F6 or Refactor | Change Signature from the menu)? That will prevent you from getting errors in the first place.



Attachment(s):
screenshot.png
0

uk chucktown wrote:

I am using the latest 9.02 release candidate but I think this is
occurring in 9.01 too. This question has been asked before but never
answered. I personally consider this a bug unless there is some
method to dismiss the popup for good. I observe the problem when I
have a method call with a bad parameter list after changing the
source method signature. As I move my mouse to highlight the bad code
and replace it, Intellij pops up a yellow dialog that covers the
source restricting me from hightlighting the code. It's very annoying
and a productivity killer when making lots of refactorings. The only
solution is resorting to the keyboard and stop using the mouse. Is
there a workaround, possibly a keyboard shortcut to dismiss the
dialog. I don't want to disable the error reporting, just the
annoying dialog that won't disappear on its own. Thanks.

--- Original message URL:
http://www.jetbrains.net/devnet/message/5260008#5260008

I see this problem too in the situation that there are many errors or
that the error runs over multiple lines.  And I too concur that it is
damn annoying.
N.

0

I did open a bug report in the issue tracker for anyone following this issue. For me it occurs on OS X. I'm able to dismiss the dialog with the ESC key but it pops up again after some delay when using the mouse for selection. Using the keyboard is a workaround but not a fix for the UI glitch.

Grant

0

Please sign in to leave a comment.