Cannot start Tomcat - localhost:8080 already in use due to avg antivirus

I have already found a similal thread
http://www.jetbrains.net/devnet/thread/279387#279387

about avg antivirus blocking idea from running tomcat on 8080 (or any other port from what I have seen) and a solution was posted there but it only applies to AVG Standard Edition since AVG Free has very few setting and does not have Tools->"Advanced setting..."->"Web Shield"-> (the web shield part is missing) nor could I find any other way to configure the ports to be scanned and remove 8080.

This happened yesterday after I downloaded an AVG update and restarted. I've now completely disabled AVG and Tomcat is launching OK from idea (so avg is definatelly the cause), but it would be nice to find a better solution and keep AVG as well.

2 comments
Comment actions Permalink

Another fix (and probably wiser imho) is to change the port that tomcat run on.  open up the <tomcat_home>/conf/server.xml and replace 8080 with 8000.  Save the file, edit your tomcat configuration in Intellij to open localhost:8000 instead of localhost:8080 and fire it up.

AVG blocking 8080 is agreeably over cautious, but imagine how upset you'd be if you had this problem and it was some spyware with an open 8080 port...

0
Comment actions Permalink

Actually, that's the bug.  The Tomcat port is not 8080, it's something else.  Yet IDEA complains that 8080 is in use (why is it bothering to check 8080 when Tomcat is not configured to start there?).

0

Please sign in to leave a comment.