Intellij deploying old and deleted packages and classes

I'm on windows using IntelliJ 9 Ultimate with JBoss 4.2.3 and I've been having this trouble since I did a move classes refactoring. I created a new package and moved a number of classes into the new package. First i noticed that the classes were duplicated in the exploded ear directory.

I've tried the folowing:

  • Invalidated Intellij cache
  • deleted the .m2 directory just in case maven was caching some jars, as there are interdependencies between the modules that make up our ear
  • deleted the entire Intellij system directory, as the invalidate cache didn't seem to make any difference
  • deleted any copy of any jar anywhere on my system
  • rebooted the system (this did actually change the behaviour) I got less copies of old jars but still I get a package with come classes in the exploded directory which does not exist in the sources
  • killed the tortoiseSVN cache process just in case that was doing something strange
  • removed all intermodule dependencies from the pom files, removed caches, deleted maven cache and restarted



Can anyone think of anything else that is resurrecting these deleted sources so they still get deployed to the exploded directory after all this? I'm beginning to think that I might have to give up on the integrated ear deployment and resort to building the ear outside of intellij and deploying that. This would be a major productivity hit at the worst time in this project you can imagine!

Something else which may be related is that when I Ctrl + click on classes in a module that is declared as a dependency I don't get the sources, only a compiled version, with a hint to attach sources.

I suspect the maven plugin has something to do with my problems. I have had endless trouble with maven, not resolving dependencies and being out of date etc.

None the less it's pretty amazing to have classes being compiled which I literally cannot find anywhere on my system!!

Please sign in to leave a comment.