After installing Mercurial integration plugin Settings window fails to open

Hello, all.
I've just installed a fresh new IntelliJ IDEA 9.0.1 and tried to install a Mercurial integration plugin.
After downloading a plugin it asked me to restart the IDE.
After restarting Settings window do not open.
I deleted Mercurial plugin manually from user plugins directory.
After that Settings window opens normally.
I'm running a Windows 7 64 bit.
This is probably a bug.
Thanks.

2 comments

Hello Denis,

I've just installed a fresh new IntelliJ IDEA 9.0.1 and tried to
install a Mercurial integration plugin.

After downloading a plugin it asked me to restart the IDE.

After restarting Settings window do not open.

I deleted Mercurial plugin manually from user plugins directory.

After that Settings window opens normally.

I'm running a Windows 7 64 bit.

This is probably a bug.


Indeed, this is a bug in the Mercurial plugin. Please use the hg4idea plugin,
which is fully compatible with recent versions of IntelliJ IDEA.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

hg4idea works well, thanks.
I've simply entered Mercurial in plugin filter and found only that old plugin.
Why is it still suggested in the list if it is not compatible?

P.S. (a little offtopic)
I'm new to IDEA. I've come to it searching for the good Scala support.
It seems that IDEA completely beats its competitors in that area. Good work

0

Please sign in to leave a comment.