@link and fully qualified class name

I searched but I couldn't find where the option to change this behaviour lies.
When I write some javadoc and insert a {@link ...} tag to a method, I'd like to make Idea use the short class name for classes which belong to the java.lang package or which are already imported.

For instance, if I start typing

  • @see Comparator#com

then CTRL+space, Idea inserts:

  • @see Comparator#compare(java.lang.Object, java.lang.Object)


Is there a way to change this?
(I also remember, at some point, there was a way to ctrl+space somewhere in the code, where, for instance a java.util.Comparator was declared, to have IDEA put java.util.Comparator in the imports and keep only Comparator in the declaration, but it doesn't seem to work like this anymore. Did I miss something? A checkbox somewhere?)

(I use EAP build 2002)

4 comments
Comment actions Permalink

I think there's something in Import options, called "use fully qualified names in javadoc."

0
Comment actions Permalink

The suggestion of unchecking "Use fully qualified names in javadoc" does work for most things, but doesn't fix the problem described with the argument list. It's quite annoying.

0
Comment actions Permalink

I've been bugged by it too: I think we should file a bug report (but am frustrated with them: mine seem to be mostly ignored).

0
Comment actions Permalink

I will file a bug report, this annoys me too much...

0

Please sign in to leave a comment.