18 comments
Comment actions Permalink


I'm on Pallada for daily use. There are a handful of annoying issues (auto-importing seems half-broken for some reason), but nothing too difficult. The Ant 1.6 support makes it worthwhile, and I want to be able to comment release by release as the dependency analysis/structured search/duplicate code detection is rolled out. Note that I'm doing pure J2SE 1.4 development, nothing too fancy.

--Dave

0
Comment actions Permalink

Jordan Zimmerman wrote:

I haven't downloaded it yet. Is anyone using it for daily work?


Yes. Pallada is workable for me, but J2EE support needs attention-- not
unexpected for the first EAP version.

Jon

0
Comment actions Permalink

I do. And it's fairly stable, IMO. The only thing that caused me some grief so far was the debugger, and I heard some people complaining about broken web app support.

I'm not using any 1.5 features, though, and the web/ejb functionality doesn't quite match my project's structure/requirements, so I barely use it.

HTH,
Andrei

JZ> I haven't downloaded it yet. Is anyone using it for daily work?
JZ>

0
Comment actions Permalink

It's pretty stable except for the debugger. Unfortunately, because I rely so heavily on remote debugging, I haven't been able to justify using it full time.

0
Comment actions Permalink

Hello Jordan,

I'm using it from Day 1 and have no problems so far.

0
Comment actions Permalink

Other than debugging, I have no problems. I do a lot of web
development, but am between cycles so I have not ran into problems there.

Norris Shelton
Sun Certified Java Programmer




Jordan Zimmerman wrote:

>I haven't downloaded it yet. Is anyone using it for daily work?
>

>

0
Comment actions Permalink

Pallada is OK if you do only standard J2SE development. It's börked if you're doing any web or ejb development.

0
Comment actions Permalink

Pallada works fine for me as the latest IDEA 4 does (desktop application
with plain Java).

Tom

0
Comment actions Permalink

"Other than the debugger?"

Let me point out the irony in that...


"The car works fine...other than the engine"
"The airplane is in good shape...other than the wings"
"My girlfriend is pretty...other than her face"
"He's really a nice guy...other than the rape convictions"

Maybe you can write bug free code the first time, and if so, I worship you.
I cant. I live by the debugger. For me (while using EAP versions), I can
live with broken refactoring, broken modules, broken CVS stuff, broken
aspects/generics stuff, broken anything....except the debugger.
System.outs wont cut it for me. Nor logging. I need realtime stepping and
breakpoints and the ability to examine the state of the system at any time.

If I am in the minority, I might wanna switch careers, cuz the competition
must be tough. Something tells me I am bound to hear the old "real
programmers dont use debuggers" routine. If so, I'll bet any amount of
money that JetBrains wont pull the debugger out of IDEA. I dare them. The
product will suddenly be as useful as Lotus 123.

As I turn to grab my Pacifico beer, I hope the debugger is soon working
again. I'm stuck using a 3.0 version of IDEA anyway, but I'd like to start
using Pallada. Aurora was hot. I loved it. I just gotta find a way to
convince the powers that be that IDEA is far better than their current
in-house standard of JBuilder. This is a big place too. Some people are
noticing I am the renegade--but they like what they see in IDEA. Give me a
few months and maybe JetBrains should see a nice purchase order hit their
mailbox.

:)





"Norris Shelton" <norrisshelton@yahoo.com> wrote in message
news:406B5D6E.3060207@yahoo.com...

Other than debugging, I have no problems. I do a lot of web
development, but am between cycles so I have not ran into problems there.

>

Norris Shelton
Sun Certified Java Programmer

>
>
>
>

Jordan Zimmerman wrote:

>

>I haven't downloaded it yet. Is anyone using it for daily work?
>
>
>



0
Comment actions Permalink

Russians say ”Fool shouldn’t see the unfinished work” (it doesn’t sound like it should when translated in English), don’t be offended by this expression, I’m not saying that anybody is full, but the work is unfinished therefore quirks should be accepted. And BTW best to my knowledge the IDEA team “write[s] bug free code the first time” and we all worship it.

0
Comment actions Permalink

This is too stupid to waste a feature request on, but:

would it be possible for someone to change the user visible version
numbers to 5.0.eap, or Pallada, so it becomes easier to distinguish it
from 4.0?

It would also be nice if the splash screen included the build number.

And whilst I'm bitching about petty things, it would also be cool if
someone could add a task to dist builder that would store the fixed in
this version bug list & open bug lists from the tracker in the readme?

Simon
p.s.
My productivity would be most enhanced if the installer could
automatically delete selected files from UT 2004, but that's a user
error :)

0
Comment actions Permalink

This is the first build of new EAP, I think it is safe to assume that a lot of stuff is probably not working correctly.

0
Comment actions Permalink

I dont know what happend to me. but pallada is totally unuseable for me. firstly, I cannot compile(the popup menu didn't have "compile" at all), I recreate the project, and the "compile" appears, but the "project setting" toolbutton became not use. I am tired of trying that, so roll back to 1977

the log shows there are some errors:
2004-04-05 09:54:28,064 ERROR - che.impl.RepositoryManagerImpl - Assertion failed: Access to psi files should be performed only after startup activity
java.lang.Throwable
at com.intellij.openapi.diagnostic.Logger.assertTrue(Logger.java:6)
at com.intellij.psi.impl.c.a.q.g(q.java:13)
at com.intellij.psi.impl.e.a.b.c(b.java:152)
at com.intellij.psi.impl.e.a.b.a(b.java:166)
at com.intellij.psi.impl.bg.findClass(bg.java:194)
at com.intellij.psi.impl.b.c.resolve(c.java:42)
at com.intellij.psi.impl.b.c.advancedResolve(c.java:7)
at com.intellij.psi.impl.source.bs.resolveGenerics(bs.java:36)
at com.intellij.psi.util.PsiUtil.resolveGenericsClassInType(PsiUtil.java:353)
at com.intellij.psi.scope.h.a(h.java:102)
at com.intellij.psi.impl.source.f.b.hasReferencedMethodCandidates(b.java:12)
at com.intellij.codeInsight.e.a.a.m.visitReferenceElement(m.java:202)
at com.intellij.codeInsight.e.a.a.m.visitReferenceExpression(m.java:471)
at com.intellij.psi.impl.source.g.a.bj.accept(bj.java:98)
at com.intellij.codeInsight.e.a.a.m.a(m.java:294)
at com.intellij.codeInsight.e.a.h.a(h.java:80)
at com.intellij.codeInsight.e.a.h.b(h.java:176)
at com.intellij.codeInsight.e.a.bk$1.run(bk$1.java:0)
at com.intellij.openapi.application.b.b.runReadAction(b.java:332)
at com.intellij.codeInsight.e.a.bk.b(bk.java:10)
at com.intellij.codeInsight.e.a.bk.access$100(bk.java:29)
at com.intellij.codeInsight.e.a.bk$0.run(bk$0.java:1)
at com.intellij.openapi.progress.b.a.runProcess(a.java:50)
at com.intellij.codeInsight.e.a.bk.run(bk.java:17)

004-04-05 09:54:30,110 ERROR - penapi.actionSystem.impl.Utils - update failed for AnAction with ID=$Undo
java.lang.NullPointerException
at com.intellij.openapi.command.impl.q.c(q.java:14)
at com.intellij.ide.actions.dw.update(dw.java:11)
at com.intellij.openapi.actionSystem.b.i.a(i.java:20)
at com.intellij.openapi.actionSystem.b.p.c(p.java:175)
at com.intellij.openapi.actionSystem.b.p$c_.c(p$c_.java:12)
at com.intellij.openapi.actionSystem.b.j.c(j.java:10)
at com.intellij.openapi.actionSystem.b.a$0.actionPerformed(a$0.java:0)
at javax.swing.Timer.fireActionPerformed(Timer.java:271)
at javax.swing.Timer$DoPostEvent.run(Timer.java:201)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
at com.intellij.ide.q.b(q.java:129)
at com.intellij.ide.q.a(q.java:105)
at com.intellij.ide.q.dispatchEvent(q.java:41)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)

java.lang.IllegalArgumentException
at java.nio.Buffer.position(Buffer.java:218)
at com.intellij.util.io.d.a(d.java:24)
at com.intellij.util.io.b.a(b.java:1)
at com.intellij.psi.impl.c.a.a.i.a(i.java:95)
at com.intellij.psi.impl.c.a.a.f.a(f.java:36)
at com.intellij.psi.impl.c.a.c.a(c.java:80)
at com.intellij.psi.impl.d.d.findFormsBoundToClass(d.java:435)
at com.intellij.codeInsight.e.a.k.b(k.java:232)
at com.intellij.codeInsight.e.a.k.a(k.java:134)
at com.intellij.codeInsight.e.a.k.a(k.java:27)
at com.intellij.codeInsight.e.a.k.a(k.java:276)
at com.intellij.codeInsight.e.a.k.a(k.java:209)
at com.intellij.codeInsight.e.a.k.b(k.java:230)
at com.intellij.codeInsight.e.a.bk$1.run(bk$1.java:0)
at com.intellij.openapi.application.b.b.runReadAction(b.java:332)
at com.intellij.codeInsight.e.a.bk.b(bk.java:10)
at com.intellij.codeInsight.e.a.bk.access$100(bk.java:29)
at com.intellij.codeInsight.e.a.bk$0.run(bk$0.java:1)
at com.intellij.openapi.progress.b.a.runProcess(a.java:50)
at com.intellij.codeInsight.e.a.bk.run(bk.java:17)

0
Comment actions Permalink

On Tue, 06 Apr 2004 02:00:07 +0000, Aeros Lau wrote:

2004-04-05 09:54:28,064 ERROR - che.impl.RepositoryManagerImpl


Sounds like a plugin there.... What plugins do you have installed?

0
Comment actions Permalink

After some continued work with EAP build 2002 and version 4.0.2 I prefer
2002 because it is more stable.

Tom

0
Comment actions Permalink

no, i have the pallada to be a new brand installation.

0
Comment actions Permalink

On Wed, 07 Apr 2004 07:20:37 +0000, Aeros Lau wrote:

no, i have the pallada to be a new brand installation.


MMmm, doyou have any form of Version Control enabled in your project?
Being that the trace mentioned "RepositoryManager" I was thinking maybe a
version control repository issue?

0
Comment actions Permalink

Working with EJBs is totally unusable (b2008) - NPE is always thrown whenever I try to edit or add something to my EJB module. Back to Aurora release :(

0

Please sign in to leave a comment.