IDEA-9 - irritating bogus notifications

I just bought myself the present I didn't get for Christmas - a license for IntelliJ IDEA 9.0 . I've been using IDEA since v7. Mind you v9 has some very good features and I'm enjoying it. At work, all our projects are Maven based and when I try to open a project with IDEA-9, I get this irritating notification - "CLASS is undefined. Fix it!" (see attached screenshot). I'm not sure if anyone else has fixed it.

I have a new iMac at home with MacOS 10.6 (Snow Leopard) at home. I'm going to try it there too, but at work it is exclusively Linux for development. Any other Linux or MacOS users experiencing this problem with IDEA-9? Dmitry - would you like me to write a ticket for this (if you are reading this)?

My environment
~~~~~~~~~~~
* Ubuntu Linux v9.10 dual core
* 2 GB main memory
* Java 6
* IntelliJ IDEA-9
* Java projects using Maven 2



Attachment(s):
Screenshot.png
3 comments
Comment actions Permalink

I was getting this, and I couldn't find what CLASS was supposed to be for, so I went into Project Settings/Path Variables and defined CLASS as CLASS... the warnings went away. I have no idea what other difference this makes.

0
Comment actions Permalink

Thanks very much. That's an excellent workaround and it worked for me. I hope that JetBrains fixes this because I'm experiencing this on MacOS (Snow Leopard) as well as Ubuntu Linux 9.10. I appreciate your letting us know how to deal with this annoying problem.

0

Please sign in to leave a comment.