Mac OS X: #939 unbearably slow

Hi,

I am using build #939 on a 1Ghz Powerbook. The problem is that IDEA is
terribly slow with my project. I wouldn't consider that project to be
big (less then 50 .java files). Editor speed is now slower than my
typing speed which is quite annoying.

One reason for the low performance that I thought of might be garbage
collection. Therefore I changed my memory settings in the plist file to
"-Xms256m -Xmx512m" (system has 1GB RAM) but the memory indicator never
shows more than 35-50MByte RAM. When the background error checker is
running I can see the memory bar increase, jump back, increase, jump
back, increase, jump back....

top says (while editing)
787 idea 68.1% 1:03.52 19 757 590 121M+ 48.4M 138M+ 621M
so I guess that it consumes more memory than it shows in the status bar.

Can any of the other Mac users (Robert?) write about their experiences
with EAP builds and their memory settings/project sizes? My system is
10.2.8 (version 1) with the JDK 1.4 update.

Dirk Dittert

8 comments
Comment actions Permalink

Dirk Dittert <dittert@despammed.com> wrote:

Therefore I changed my memory settings in the plist file to
"-Xms256m -Xmx512m" (system has 1GB RAM) but the memory indicator never
shows more than 35-50MByte RAM.


I just checked: 3.0.4 shows right after starting the IDE with these
settings: "16 of 256MB" whereas #939 shows "31 of 34MB". That's weird.
Did I change the wrong settings?

Dirk Dittert

0
Comment actions Permalink

Dirk Dittert <dittert@despammed.com> wrote:

I just checked: 3.0.4 shows right after starting the IDE with these
settings: "16 of 256MB" whereas #939 shows "31 of 34MB". That's weird.
Did I change the wrong settings?


Ok, I got that fixed. Just from watching the memory bar at the bottom of
the frame, I still have the feeling that gc is running a lot more with
current builds than with 3.0.4. Memory consumption with 3.0.4 is up over
100MByte after an hour of working. #939 still doesn't get over
40-50MByte. Either it consumes a lot less memory or gc is killing the
caches all the time...

Dirk Dittert

0
Comment actions Permalink

In article <1g2dbuu.1y9jgp0dtfv30N%dittert@despammed.com>,
dittert@despammed.com (Dirk Dittert) wrote:

Can any of the other Mac users (Robert?) write about their experiences
with EAP builds and their memory settings/project sizes? My system is
10.2.8 (version 1) with the JDK 1.4 update.


I set mine at 64 and 512 usually. Sometimes 32 and 384. I have no idea
what I should be setting those values at. I wish the installer would
recommend something and do this for me.

My project is about 3500 classes. My computer is a dual 1.25 GHz G4. I'm
using the non-updated 1.4 VM.

IDEA is fast, but in the past couple builds there have been itermittant
pauses lasting 3 to 8 seconds or so. I was going to submit a bug report
if it kept happening after I update the VM, which I haven't gotten
around to doing yet.

0
Comment actions Permalink

Erik Hanson <ehanson-lists@eh.cdeh.org> wrote:

My project is about 3500 classes. My computer is a dual 1.25 GHz G4. I'm
using the non-updated 1.4 VM.

IDEA is fast, but in the past couple builds there have been itermittant
pauses lasting 3 to 8 seconds or so. I was going to submit a bug report
if it kept happening after I update the VM, which I haven't gotten
around to doing yet.


What does the memory indicator show after working for an hour? I also do
have those pauses (gc while code checker runs in the background?)


Dirk Dittert

0
Comment actions Permalink

In article <1g2gn3t.8mo6d31ms1cotN%dittert@despammed.com>,
dittert@despammed.com (Dirk Dittert) wrote:

Erik Hanson <ehanson-lists@eh.cdeh.org> wrote:

My project is about 3500 classes. My computer is a dual 1.25 GHz G4. I'm
using the non-updated 1.4 VM.

IDEA is fast, but in the past couple builds there have been itermittant
pauses lasting 3 to 8 seconds or so. I was going to submit a bug report
if it kept happening after I update the VM, which I haven't gotten
around to doing yet.


What does the memory indicator show after working for an hour? I also do
have those pauses (gc while code checker runs in the background?)


It currently says "40M of 81M". After running a search through the
entire path, it says "92M of 128M".

0
Comment actions Permalink

Here are the IDEA VM settings I use, they seem to work out pretty well for me.

IDEA_JVM_ARGS=-Didea.no.jdk.check=true -Xms16m -Xmx512m -XX:NewRatio=3 -XX:UseParNewGC -XX:UseConcMarkSweepGC -Dsun.java2d.noddraw=true

0
Comment actions Permalink

Can you tell us where that IDEA_JVM_ARGS variable is set?

Anybody else have this extremely annoying issue?

Thanks!

0
Comment actions Permalink

Paolo Resmini wrote:
> Can you tell us where that IDEA_JVM_ARGS variable is set?

It's in ]]>/Contents/info.plist


Alain

0

Please sign in to leave a comment.