Cannot Validate 2.4 Web.xml file

I'm using the latest build of IDEA (1174) and my web.xml file shows up with lots of red! The XML file looks like this

<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
version="2.4">

<context-param>
<param-name>javax.servlet.jsp.jstl.fmt.localizationContext</param-name>
<param-value>com.develop.ejweb.resources.ApplicationResources</param-value>
</context-param>


etc...

I have a web module setup.
I have the web.xml set in the Deployment descriptor location.
The namespace looks right
The schema is right

I'm sure this was working in previous builds (although not 1172, which is why I upgraded).

One thing I am noticing is that when I choose this XML as the deployment descriptor I cannot set the version to 2.4. Everytime I set the version IDEA sets it back to 2.3. I assume this is part of the problem.

Am I missing something obvious?

Thanks

Please sign in to leave a comment.