maven earSourceDirectory ignored (META-INF/**.* ear files not deployed)

I was looking for an existing solution to this but can't found one, cause I'm not really a IDEA user I decided to start this thread before submiting a bug.

Supose You have a maven-ear-plugin project with the  specified - seems to be ignored by the IDEA plugin, now why does this matter :

I'm using WebLogic Portal 10.3, but I can imagine other app servers having additional descriptors in .ear/META-INF except for application.xml and the app server specific descriptor (e.g. weblogic-application.xml) IDEA is capable of detecting. I've tried adding the ear source directory as an IDEA source directory but still no result when I deploy to weblogic (tried autodeploy as well as weblogic deployer) I only see application.xml and weblogic-application.xml under META-INF in the .ear's deployed files (and that's cause I set them up in the JavaEE facet) but the ear source directory contains a bunch of other portal related xml files as well ...

Even tried setting up a resource directory in maven (with a META-INF target) and reimporting the project, but no luck ... am I missing smt obvious in IDEA ?

This is somehow driving me nuts, please note that the generated .ear deploys correctly from other IDEs and when build and deployed by hand ...

Thank You for any advise, I was trying this under IDEA 9.0 as well as 8.1.x

---
Original message URL: http://www.jetbrains.net/devnet/message/5252999#5252999

Please sign in to leave a comment.