unable to get a working grails project from existing sources - any ideas why?

Hi

I just upgraded to IDEA 9.0 on a newer computer.  I am using grails 1.1.2 and groovy 1.6.7, jdk1.6.0_17.

I have been using Grails and groovy for a couple of years and IDEA since 1999.

I have a grails project and selected "Import Grails application from existing sources" and I started to have problems.  So in order to figure out what was happening, I created a straight forward grails miminal example called test.  It runs exactly as expected from the command line (grails run-app).

the resulting project won't compile.  

After I select the source directories it tells me that "Cannot find Groovy home for module "test". You should either -invoke Framework support action for this module or ....

I cannot create a runnable application.  There is no module drop down for it as well.

I have JAVA_HOME< GROOVY_HOME and GRAILS_HOME set and they can all be seen if you execute java -version, groovy -version or grails -version from the command line.



In fact if I create a new project from the wizard then all that is there is the "src" directory

All of this worked great in Intellij 8.  I have tried to figure out what was wrong and I have no idea why.

In fact when I used the IDEA 9 beta on older projects I could see a grails tab on the left side.  I was quick excited at this and went whole hog and installed IDEA 9 on my new laptop.

Any suggestions would be appreciated

Thanks
Larry
2 comments
Comment actions Permalink

I finally figured it out.

Somehow the grails and groovy global libs were corrupted.  

I managed to get Idea to recreate them and all was well

So please ignore

0
Comment actions Permalink

How did you get IDEA to recreate them?

0

Please sign in to leave a comment.