IntelliJ 9 is still a beta application!

I really have enough of all those softwares that are released like final products but are in reality a simple public beta!!

This new IntelliJ 9 is just that!
I just lost almost a full day of job because of that and I now need to go back to my version 7!

It fist took me a couple of hours just to make my project work under v9. It didn't want to run (under Tomcat 6) with a very descriptive error message: "Error: '/lib' is a directory"!!!
After palying around with the "artifacts" section in the project configuration, I fixed it. Since then, it is crash after crash after crash. That mean the application quit without any error message or simply freeze. And that live thousands of "threadDump-....txt" log files on my hd!!

And of course when I do a "Force Quit" (I am on Mac OS), the next time I start it, it have to redo the indexation!!! And that can take more than 10 minutes with 100% CPU usage!

Please text and fix your beta application before releasing it! We are not beta testers, we are developers!


I don't have that feeling at all. I've been working with 9.0 for a couple of days and it seems very solid to me. It does not seem fair to me to generalize your particular problem in that way ("still a beta application") . Also, if you get crashes, it's likely a problem with the JRE, not with IntelliJ IDEA.


Hi Thierry,

I'm really surprised that you encounter so much trouble with the new version - I'm using IDEA 9 on two systems running OSX and Ubuntu and have not encountered any major problem at all.
There are some plugins that have not yet been updated, but apart from that, I really enjoy the new version.

While I can understand that you are angry, I think your harsh criticism is a bit unfair.
There has been a lot of feedback from beta testers participating in the EAP and there seems to be no one in the EAP that had the same major problems.
It is not like there have been people saying: "IDEA9 isn't working at all on my system" and Jetbrains said: "Well, we don't care - we release it anyway".

So to my mind, your specific system configuration seems to create major problems that have not been encountered by anyone participating in the EAP.
Obviously, that is annoying for you but in order to help you quickly, you should create a new ticket in youtrack and include as much information as possible (what you did, stacktraces from the idea log, system specs, java version, etc).

One last thought: is it possible that IDEA9 picked up a plugin from you old installation and that plugin is causing the trouble ?
I'm not sure wether that could have happened but disabling all third party plugins might help in locating the problem.


I am trying to be fair... but it his very hard to not be frustrated about it. I didn't install any EAP release neither the beta version because I really wanted to wait for the final version to avoid problems and time lost.
Again in the last 24h, it frozed about 5 more times!
It have nothing to do with third party plugins. The only one I have is "TabSwitch". And I installed it only late yesterday. The freezes happened a lot of time before that.
I have all the latest MacOS Updates (10.6.2) and also the latest JDK/JRE installed.
I also tried adding the "IDEA_JDK" environment variable to use a specific JDK (it points to my Java 6 "/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home"). It doesn't change anything.

The project I am working on is very very complex. More than 20 modules and close to 5000 clases. We are also using about 45 third party libraries. Everything is run under Java 6 and deployed under Tomcat 6. All the latest version are used.

All that is working perfectly with IntelliJ 7.0.5.

We were planning to upgrade to version 9 (about 10 licenses), but I guess we will have to wait...

Here's attached, my latest logs of this morning when it frozed again (I had to do a force quit).


Please sign in to leave a comment.