Cannot launch IntellIJ 8.1.3 after applying 1.6.0 update 1

After applying update 1 to my Snow Leopard 1.6.0 such that

audrey:Java For Mac OS X 10.6 Update 1 robert$ java -version
java version "1.6.0_17"
Java(TM) SE Runtime Environment (build 1.6.0_17-b02-231)
Java HotSpot(TM) 64-Bit Server VM (build 14.3-b01-95, mixed mode)


...

IntelliJ won't launch anymore.

Date/Time:       2009-10-12 10:38:54.087 -0500
OS Version:      Mac OS X 10.6.1 (10B504)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  4
8 comments
Comment actions Permalink

Same issue here...  What gives!!!!!?????

Process:         JavaApplicationStub [588]
Path:            /Applications/IntelliJ IDEA 8.1.4.app/Contents/MacOS/idea
Identifier:      com.jetbrains.intellij
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [281]

Date/Time:       2009-12-03 16:51:13.771 -0500
OS Version:      Mac OS X 10.6.2 (10C540)
Report Version:  6

Interval Since Last Report:          216159 sec
Crashes Since Last Report:           11
Per-App Crashes Since Last Report:   2
Anonymous UUID:                      2607822B-6952-4F94-A825-73863B3117AE

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  4

Thread 0:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib                 0x93a598da mach_msg_trap + 10
1   libSystem.B.dylib                 0x93a5a047 mach_msg + 68
2   com.apple.CoreFoundation          0x90b6877f __CFRunLoopRun + 2079
3   com.apple.CoreFoundation          0x90b67864 CFRunLoopRunSpecific + 452
4   com.apple.CoreFoundation          0x90b67691 CFRunLoopRunInMode + 97
5   ...ple.JavaApplicationLauncher    0x0001358e startupJava(LauncherArgsStruct*) + 342
6   ...ple.JavaApplicationLauncher    0x000128cf launchJavaApplication + 1355
7   JavaApplicationStub               0x00001e3a 0x1000 + 3642
8   JavaApplicationStub               0x00001c99 0x1000 + 3225
9   JavaApplicationStub               0x00001bc8 0x1000 + 3016

...blah, blah, blah...

0
Comment actions Permalink

After applying update 1 to my Snow Leopard 1.6.0 such that


java version "1.6.0_17"
...


IntelliJ won't launch anymore.

Me too.  Ugh.

0
Comment actions Permalink

I was able to resolve this issue by following the instructions on the web site below to install Java 1.5.0.

http://wiki.oneswarm.org/index.php/OS_X_10.6_Snow_Leopard

Thankfully I don't have a dependency on Java 6.  Good luck!

0
Comment actions Permalink

Thanks, Justin.  You jogged my memory.  I had earlier installed Java 1.5 on my Snow Leopard machine and tweaked the links, but the Java 1.6 update stomped on my configuration.  The recipe I use is this one: http://chxor.chxo.com/post/183013153/installing-java-1-5-on-snow-leopard, which uses Pacifist and an official Apple Java distribution.

0
Comment actions Permalink

I'll add mine to the WTF list. This has happened with previous java patches from apple, at this point i get scared whenever i see a new java update pending in OSX! Anyway reverting to 1.5 didn't work for me, anyone else get passed this using 64 bit 1.6?

slighty sanitized stack trace:

Process:         idea [5350]
Path:            /Applications/IntelliJ IDEA 8.1.4.app/Contents/MacOS/idea
Identifier:      com.jetbrains.intellij
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [498]

Date/Time:       2009-12-08 07:47:40.213 -0500
OS Version:      Mac OS X 10.6.2 (10C540)
Report Version:  6

Interval Since Last Report:          2421419 sec
Crashes Since Last Report:           8
Per-App Crashes Since Last Report:   8
Anonymous UUID:                      79DA228E-02B9-4AE6-8225-1E09E35B42AA

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  4

Thread 0:  Dispatch queue: com.apple.main-thread

Thread 1:
0   libSystem.B.dylib                 0x93553182 __workq_kernreturn + 10
1   libSystem.B.dylib                 0x93553718 _pthread_wqthread + 941
2   libSystem.B.dylib                 0x93553336 start_wqthread + 30

Thread 2:  Dispatch queue: com.apple.libdispatch-manager
0   libSystem.B.dylib                 0x935540ea kevent + 10
1   libSystem.B.dylib                 0x93554804 _dispatch_mgr_invoke + 215
2   libSystem.B.dylib                 0x93553cc3 _dispatch_queue_invoke + 163
3   libSystem.B.dylib                 0x93553a68 _dispatch_worker_thread2 + 234
4   libSystem.B.dylib                 0x935534f1 _pthread_wqthread + 390
5   libSystem.B.dylib                 0x93553336 start_wqthread + 30

Thread 3:
0   libzip.jnilib                     0x000e2c32 0xe1000 + 7218
1   libzip.jnilib                     0x000ebdb5 ZIP_ReadEntry + 387
2   libclient.dylib                   0x004a841c 0x400000 + 689180

27  libclient.dylib                   0x005f6d49 JNI_CreateJavaVM_Impl + 185
28  ...ple.JavaApplicationLauncher    0x0000a28e startJavaApplication + 3134
29  ...ple.JavaApplicationLauncher    0x0000964e runJava(LauncherArgsStruct*) + 78
30  ...ple.JavaApplicationLauncher    0x000095f8 java_main_stub(void*) + 22
31  libSystem.B.dylib                 0x9355afbd _pthread_start + 345
32  libSystem.B.dylib                 0x9355ae42 thread_start + 34

Thread 4 Crashed:
5   libSystem.B.dylib                 0x9359954c mach_msg_server + 380
6   libclient.dylib                   0x0040eb75 0x400000 + 60277
7   libclient.dylib                   0x0040e935 0x400000 + 59701
8   libclient.dylib                   0x006c54f5 JVM_RaiseSignal + 441397
9   libSystem.B.dylib                 0x93623e52 _pthread_body + 27

Thread 4 crashed with X86 Thread State (32-bit):
  eax: 0x00000000  ebx: 0x004fee3b  ecx: 0x00000000  edx: 0x0000001e
  cr2: 0x00000000

Binary Images:
    0x1000 -     0x2fff +com.jetbrains.intellij 8.1.4 (9952) /Applications/IntelliJ IDEA 8.1.4.app/Contents/MacOS/idea
    0x7000 -    0x11ff7  com.apple.JavaApplicationLauncher 13.1.0 (13.1.0) <4AC23F10-15F8-A81C-A1A0-89FA16CC14FB> /System/Library/PrivateFrameworks/JavaApplicationLauncher.framework/Versions/A/JavaApplicationLauncher
   0x19000 -    0x20ff7  com.apple.JavaVM 13.1.0 (13.1.0) <2842C4EE-869D-81E6-E771-062F583A1044> /System/Library/Frameworks/JavaVM.framework/Versions/A/JavaVM
   0x82000 -    0x8aff7  libverify.dylib ??? (???) <0E0C6835-68C5-A72F-8CA0-77857B632513> /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libverify.dylib
   0x8f000 -    0x96ff7  JavaNativeFoundation ??? (???) <1107BBC2-DFC1-CF1F-44EE-27F7D4349BE6> /System/Library/Frameworks/JavaVM.framework/Versions/A/Frameworks/JavaNativeFoundation.framework/Versions/A/JavaNativeFoundation
   0xb2000 -    0xcfff7  libjava.jnilib ??? (???) <C4C57812-6A25-85AB-441B-DE1A71A8DF18> /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libjava.jnilib
   0xe1000 -    0xedff7  libzip.jnilib ??? (???) <1317EACC-2494-70C3-4B43-FC9D04579EAF> /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libzip.jnilib
  0x400000 -   0x750ffb  libclient.dylib ??? (???) <A1BC00EA-6C14-2A98-3CA4-CA910B38771C> /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0-leopard/Libraries/libclient.dylib
0x1100000 -  0x14f6fe7  libclient.dylib ??? (???) <6B8B4A7E-2844-3AD6-239E-122121D37485> /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Libraries/libclient.dylib
0x8fe00000 - 0x8fe4162b  dyld 132.1 (???) <211AF0DD-42D9-79C8-BB6A-1F4BEEF4B4AB> /usr/lib/dyld
0x90003000 - 0x90185fe7  libicucore.A.dylib ??? (???) <2B0182F3-F459-B452-CC34-46FE73ADE348> /usr/lib/libicucore.A.dylib

BLAH BLAH BLAH

0
Comment actions Permalink

I have the same problem. Eclipse won´t start either.

Any help is appreciated.

0
Comment actions Permalink

Hello Jean Carlo Favila Humara,

I have the same problem. Eclipse won´t start either.

Any help is appreciated.


http://jetbrains.net/devnet/docs/DOC-1183

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Just as a follow on from my previous post.  Even though I have to set Java 5 as my default Java, I can still develop Java applications in IntelliJ that require Java 6.  I just specify the appropriate JDK in the Project Settings.  So far, Java 6 has worked fine in that context.  It's just when I want to run IntelliJ using Java 6 that all hell breaks loose.

0

Please sign in to leave a comment.