XSD problems with IDEA 8.1.4

Hi,

I just installed IDEA 8.1.4 and my Facelets (*.xhtml) started showing errors.

As a first example, the ui:composition and ui:include behave differently (see facelets.png attached). The ui:composition is complaining when there are two ui:define elements in a sequence and the ui:include one always wants a ui:param specified.

Maybe IDEA is more strict with its checks in the last version but in this case the XSD file should be fixed to allow syntax that is otherwise working in runtime.

As a second example, custom taglibs have problems with validation (see taglib.png attached). IDEA navigates to the authorize tag:

<facelet-taglib xmlns="http://java.sun.com/JSF/Facelet">
  <namespace>http://xx.xx.xx/xx</namespace>
  <tag>
    <tag-name>authorize</tag-name>
    <handler-class>xx.xx.xx.view.security.tags.AuthorizeTag</handler-class>
  </tag>


Here is the XSD for the custom taglib:

<xsd:schema 
            xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            targetNamespace="http://xx.xx.xx/xx"
            elementFormDefault="qualified"
            attributeFormDefault="unqualified">


When used, IDEA complains that no declaration of the element autorize can be found and taglib is not a element. In this case, I cannot define well what is wrong.



Attachment(s):
taglib.png
facelets.png
4 comments
Comment actions Permalink

As a workaround, you can turn off Xerces validation inspection (Project
Settings -> Errors -> XML -> File does not pass external validation).
Please file a ticket for the problem.


0
Comment actions Permalink

Thanks Dmitry,

Ticket ID: IDEA-26096

BTW I have several other warning messages in my Facelet file and I thought it'll be ok to have it as a warning too. So I tried to change the validation from 'error' to 'warning'. Well that didn't work and it stayed red. Only when I disable it, it is hidden. Is it supposed to be like that?

0
Comment actions Permalink

No, it is not. Please file another issue for that.


0

Please sign in to leave a comment.