8.1.4 doesn't start on Mac OS 10.6.2

I downloaded 8.1.4 this morning and tried to run it. The splash screen appears but then just hangs there. I don't see any error message in my system.log. I can't find any IntelliJ log so not sure if there is another log I can check.

Using 10.6.2.

Anyone else have a simliar problem?

7 comments
Comment actions Permalink

Ok, I found idea.log in ~/Library/Caches/IntelliJIDEA8x/log it has this error, maybe a problem with one of my plugins?

2009-11-16 09:45:19,170 [      0]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDEA STARTED ------------------------------------------------------
2009-11-16 09:45:33,963 [  14793]  ERROR - com.intellij.ide.IdeEventQueue - Error during dispatching of java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=com.intellij.idea.MainImpl$3@9c7bfc,notifier=null,catchExceptions=false,when=1258386328716] on apple.awt.CToolkit@8fe358
java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:675)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:520)
    at com.intellij.util.lang.UrlClassLoader._defineClass(UrlClassLoader.java:119)
    at com.intellij.util.lang.UrlClassLoader.defineClass(UrlClassLoader.java:115)
    at com.intellij.util.lang.UrlClassLoader._findClass(UrlClassLoader.java:91)
    at com.intellij.ide.plugins.cl.PluginClassLoader.loadClassInsideSelf(PluginClassLoader.java:78)
    at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:41)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:374)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:242)
    at com.intellij.openapi.extensions.impl.ExtensionComponentAdapter.loadClass(ExtensionComponentAdapter.java:140)
    at com.intellij.openapi.extensions.impl.ExtensionComponentAdapter.getComponentImplementation(ExtensionComponentAdapter.java:61)
    at com.intellij.openapi.extensions.impl.ExtensionComponentAdapter.getComponentInstance(ExtensionComponentAdapter.java:67)
    at com.intellij.openapi.extensions.impl.ExtensionComponentAdapter.getExtension(ExtensionComponentAdapter.java:106)
    at com.intellij.openapi.extensions.impl.ExtensionPointImpl.processAdapters(ExtensionPointImpl.java:201)
    at com.intellij.openapi.extensions.impl.ExtensionPointImpl.getExtensions(ExtensionPointImpl.java:150)
    at com.intellij.openapi.extensions.Extensions.getExtensions(Extensions.java:99)
    at com.intellij.openapi.extensions.Extensions.getExtensions(Extensions.java:87)
    at com.intellij.openapi.fileTypes.impl.FileTypeManagerImpl.<clinit>(FileTypeManagerImpl.java:163)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:242)
    at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:32)
    at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:45)
    at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.access$100(ComponentManagerImpl.java:54)
    at com.intellij.openapi.components.impl.ComponentManagerImpl.a(ComponentManagerImpl.java:70)
    at com.intellij.openapi.components.impl.ComponentManagerImpl.initComponents(ComponentManagerImpl.java:128)
    at com.intellij.openapi.components.impl.stores.ApplicationStoreImpl.load(ApplicationStoreImpl.java:7)
    at com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:135)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:41)
    at com.intellij.idea.MainImpl$3.run(MainImpl.java:1)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
    at com.intellij.ide.IdeEventQueue.c(IdeEventQueue.java:57)
    at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:99)
    at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:189)
    at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

0
Comment actions Permalink

It looks like one or more of your plugins were compiled using jdk 1.6 and you are running IntelliJ IDEA on jdk 1.5. Which is strange because you are on Snow Leopard and are not supposed to have jdk 1.5... Perhaps the plugin was compiled with jdk 1.7 or was corrupted somehow.

Bas

0
Comment actions Permalink

I'm also seeing this on 10.5 [waiting for a new hard disk to upgrade to 10.6]

In a terminal window, java version reports as 1.5.0_20 no matter what is specified in the java preferences [currently set to 1.6 before any older versions [1.5 64 bit, 1.5 32 bit & 1.4.1]]

Perhaps the OS needs a restart to have the change take effect.

On the other hand, installing the 8.1.4 image broke the 8.1.3 install - at a guess something in the Idea cache / settings area was changed and is no longer compatible.

0
Comment actions Permalink

I changed my Info.plist to run IntelliJ 8.1.4 with 1.6 and all is well.

I have 1.5 on Snow Leopard because I pulled it over from a machine with Leopard.

0
Comment actions Permalink

Well, at least on 10.5 that does not help

[log]

2009-11-19 09:51:12,582 [      0]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDEA STARTED ------------------------------------------------------
2009-11-19 09:51:15,535 [   2953]  ERROR - llij.ide.plugins.PluginManager - Expected implementation for extension declaration (ep = com.intellij.completion.contributor)
java.lang.RuntimeException: Expected implementation for extension declaration (ep = com.intellij.completion.contributor)
 at com.intellij.openapi.extensions.impl.ExtensionsAreaImpl.registerExtension(ExtensionsAreaImpl.java:134)
 at com.intellij.openapi.extensions.impl.ExtensionsAreaImpl.registerAreaExtensionsAndPoints(ExtensionsAreaImpl.java:313)
 at com.intellij.ide.plugins.IdeaPluginDescriptorImpl.setLoader(IdeaPluginDescriptorImpl.java:365)
 at com.intellij.ide.plugins.PluginManager.initializePlugins(PluginManager.java:202)
 at com.intellij.ide.plugins.PluginManager.getPlugins(PluginManager.java:87)
 at com.intellij.openapi.application.impl.ApplicationImpl.e(ApplicationImpl.java:327)
 at com.intellij.openapi.application.impl.ApplicationImpl.<init>(ApplicationImpl.java:221)
 at com.intellij.openapi.application.ex.ApplicationManagerEx.createApplication(ApplicationManagerEx.java:7)
 at com.intellij.idea.IdeaApplication.<init>(IdeaApplication.java:26)
 at com.intellij.idea.MainImpl.a(MainImpl.java:1)
 at com.intellij.idea.MainImpl.access$000(MainImpl.java:33)
 at com.intellij.idea.MainImpl$2.proceed(MainImpl.java)
 at com.intellij.ide.a.c.j$10.run(j$10.java:2)
 at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
 at java.awt.EventQueue.dispatchEvent(EventQueue.java:633)
 at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
 at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
 at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
2009-11-19 09:51:15,538 [   2956]  ERROR - llij.ide.plugins.PluginManager - JDK: 1.6.0_15
2009-11-19 09:51:15,538 [   2956]  ERROR - llij.ide.plugins.PluginManager - VM: Java HotSpot(TM) 64-Bit Server VM
2009-11-19 09:51:15,538 [   2956]  ERROR - llij.ide.plugins.PluginManager - Vendor: Apple Inc.
2009-11-19 09:51:15,538 [   2956]  ERROR - llij.ide.plugins.PluginManager - OS: Mac OS X


[/log]

I'm going to try this again setting the java version in the plist to 1.5, and putting the 32 bit version before the 64 bit version
0
Comment actions Permalink

An 'maia' build 10781 has no trouble launching and running with the default .app bundle [different cache directory?]

0
Comment actions Permalink

If you are trying to run Maia and 8.1.x you may be being affected by this:

http://www.jetbrains.net/devnet/thread/284071?tstart=0

0

Please sign in to leave a comment.